<!DOCTYPE html><html lang="en"><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<meta charset="utf-8" />

<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<style>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</style>


<title>It&#39;s A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who | TV | TellyMix</title>


<link rel="icon" href="/favicon.ico" type="image/x-icon" />
<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" href="/icon.png" />
<link rel="preconnect" href="//i0.wp.com" />
<link rel="preconnect" href="//i1.wp.com" />
<link rel="preconnect" href="//i2.wp.com" />
<link rel="preconnect" href="//c0.wp.com" />


<meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1" />

<meta name="description" content="It&#39;s A Sin star Omari Douglas has been tipped to takeover from Jodie Whittaker on Doctor Who. It was confirmed recently that Jodie is to step down from" />
<link rel="canonical" href="https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="It&#39;s A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who" />
<meta property="og:description" content="Latest rumoured name" />
<meta property="og:url" content="https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html" />
<meta property="og:site_name" content="TellyMix" />
<meta property="article:publisher" content="http://facebook.com/tellymix" />
<meta property="article:published_time" content="2021-11-03T17:51:17+00:00" />
<meta property="og:image" content="https://tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="It&#39;s A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who" />
<meta name="twitter:description" content="Latest rumoured name" />
<meta name="twitter:creator" content="@tellymix" />
<meta name="twitter:site" content="@tellymix" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://tellymix.co.uk/#organization","name":"TellyMix","url":"https://tellymix.co.uk/","sameAs":["http://facebook.com/tellymix","http://instagram.com/tellymix","http://youtube.com/tellymixcouk","https://twitter.com/tellymix"],"logo":{"@type":"ImageObject","@id":"https://tellymix.co.uk/#logo","inLanguage":"en-GB","url":"https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/tellymix-logo-edit.jpg?fit=1920%2C1080&ssl=1","contentUrl":"https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/tellymix-logo-edit.jpg?fit=1920%2C1080&ssl=1","width":1920,"height":1080,"caption":"TellyMix"},"image":{"@id":"https://tellymix.co.uk/#logo"}},{"@type":"WebSite","@id":"https://tellymix.co.uk/#website","url":"https://tellymix.co.uk/","name":"TellyMix","description":"Reality telly goodness","publisher":{"@id":"https://tellymix.co.uk/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://tellymix.co.uk/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","@id":"https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html#primaryimage","inLanguage":"en-GB","url":"https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?fit=1920%2C1080&ssl=1","contentUrl":"https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?fit=1920%2C1080&ssl=1","width":1920,"height":1080,"caption":"Omari Douglas"},{"@type":"WebPage","@id":"https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html#webpage","url":"https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html","name":"It's A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who | TV | TellyMix","isPartOf":{"@id":"https://tellymix.co.uk/#website"},"primaryImageOfPage":{"@id":"https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html#primaryimage"},"datePublished":"2021-11-03T17:51:17+00:00","dateModified":"2021-11-03T17:51:17+00:00","description":"It's A Sin star Omari Douglas has been tipped to takeover from Jodie Whittaker on Doctor Who. It was confirmed recently that Jodie is to step down from","breadcrumb":{"@id":"https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html#breadcrumb"},"inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html"]}]},{"@type":"BreadcrumbList","@id":"https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://tellymix.co.uk/"},{"@type":"ListItem","position":2,"name":"News","item":"https://tellymix.co.uk/tv-news"},{"@type":"ListItem","position":3,"name":"It's A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who"}]},{"@type":["Article","NewsArticle"],"@id":"https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html#article","isPartOf":{"@id":"https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html#webpage"},"author":{"@id":"https://tellymix.co.uk/#/schema/person/e4de7a2b4a6f28cb79f572eb0ddee66b"},"headline":"It's A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who","datePublished":"2021-11-03T17:51:17+00:00","dateModified":"2021-11-03T17:51:17+00:00","mainEntityOfPage":{"@id":"https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html#webpage"},"wordCount":381,"publisher":{"@id":"https://tellymix.co.uk/#organization"},"image":{"@id":"https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html#primaryimage"},"thumbnailUrl":"https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?fit=1920%2C1080&ssl=1","keywords":["Doctor Who","It's A Sin","Omari Douglas"],"articleSection":["TV"],"inLanguage":"en-GB","copyrightYear":"2021","copyrightHolder":{"@id":"https://tellymix.co.uk/#organization"}},{"@type":"Person","@id":"https://tellymix.co.uk/#/schema/person/e4de7a2b4a6f28cb79f572eb0ddee66b","name":"Annaleigh Rose Clarke","description":"Annaleigh joined TellyMix in 2017 and writes regular on all things TV from ratings to who left The X Factor this week.","url":"https://tellymix.co.uk/author/annaleigh"}]}</script>

<link rel="dns-prefetch" href="//c0.wp.com" />
<link rel="dns-prefetch" href="//i0.wp.com" />
<link rel="dns-prefetch" href="//i1.wp.com" />
<link rel="dns-prefetch" href="//i2.wp.com" />
<link rel="stylesheet" id="mediaelement-css" href="https://c0.wp.com/c/5.7.3/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css" type="text/css" media="all" />
<link rel="stylesheet" id="wp-mediaelement-css" href="https://c0.wp.com/c/5.7.3/wp-includes/js/mediaelement/wp-mediaelement.min.css" type="text/css" media="all" />
<style id="rocket-lazyload-inline-css" type="text/css">
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://tellymix.co.uk/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<link rel="https://api.w.org/" href="https://tellymix.co.uk/wp-json/" /><link rel="alternate" type="application/json" href="https://tellymix.co.uk/wp-json/wp/v2/posts/599048" /><link rel="alternate" type="application/json+oembed" href="https://tellymix.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftellymix.co.uk%2Ftv%2F599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html" />
<link rel="alternate" type="text/xml+oembed" href="https://tellymix.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftellymix.co.uk%2Ftv%2F599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html&amp;format=xml" />
<link rel="amphtml" href="https://tellymix.co.uk/amp/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html" /><style type="text/css">img#wpstats{display:none}</style>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>

<meta name="google-site-verification" content="zMfeaeis4_OBoy3NMgj_KUI-SF45iLK_DPK59SmYPnQ" />
<meta name="msvalidate.01" content="D7822FBA592ED89AF5EB1836F67784FF" />
<link href="https://plus.google.com/108558804266181771802" rel="publisher" />
<meta property="fb:pages" content="347362787491" />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />

<script async="" src="https://www.googletagmanager.com/gtag/js?id=UA-20273164-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20273164-1');
</script>
<script async="" type="text/javascript" src="//s.clickiocdn.com/t/consent_194647.js"></script>

<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-7416743337323842",
    enable_page_level_ads: true
  });
</script>
<script async="" type="text/javascript" src="//s.clickiocdn.com/t/194647/360_light.js"></script>
<link href="https://s.clickiocdn.com/t/static/prism_feed.min.css" rel="stylesheet" />
<script src="https://s.clickiocdn.com/t/static/prism_feed.min.js" defer=""></script>
<script async="" type="text/javascript" src="//s.clickiocdn.com/t/194647/360_light.js"></script>
<script>
        document.addEventListener("DOMContentLoaded", () => {
            if (typeof infiniteScroll !== "undefined") {
                new infiniteScroll({
                    element: ".bsc > p:last-of-type",
                    googleAnalyticsSettings: {
                        gaTrackingId: "UA-20273164-1",
                        gaType: "gtag"
                    },
                    maxScrollElements: 2
                });
            }
        });
</script>
</head>
<body>

<style type="text/css">div.mpuslot { width: auto !important; height: auto !important; }
div.mpuslot-float-none { padding:0 !important; } 
</style>

<div id="mobile-sidebar" class="no-amp-sidebar">
<ul>
<li class="menu-spacer">TellyMix</li>
<li class="close-menu-button"> <button on="tap:mobile-sidebar.close" role="button" id="close-menu" tabindex="0">Close Menu</button></li>
<li><a href="/">Home</a></li>
<li><a href="/tv-news">All TV News</a></li>
<li class="navsearch noborderright">
<form method="get" action="https://tellymix.co.uk/">
<div>
<input type="text" placeholder="Search..." name="s" id="ns" />
</div>
</form>
</li>
<li id="menu-item-573748" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573748"><a href="https://tellymix.co.uk/tag/love-island">Love Island</a></li>
<li id="menu-item-573745" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573745"><a href="https://tellymix.co.uk/tag/strictly-come-dancing">Strictly Come Dancing</a></li>
<li id="menu-item-573743" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573743"><a href="https://tellymix.co.uk/tag/great-british-bake-off">Great British Bake Off</a></li>
<li id="menu-item-573742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-573742"><a href="https://tellymix.co.uk/streaming">Streaming</a></li>
<li id="menu-item-573746" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573746"><a href="https://tellymix.co.uk/tag/im-a-celebrity">I&#39;m A Celebrity</a></li>
<li id="menu-item-578426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-578426"><a href="https://tellymix.co.uk/tag/the-voice-uk">The Voice UK</a></li>
<li id="menu-item-428525" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-428525"><a href="https://tellymix.co.uk/tag/the-masked-dancer">The Masked Dancer</a></li>
<li id="menu-item-578427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-578427"><a href="https://tellymix.co.uk/tag/dancing-on-ice">Dancing On Ice</a></li>
<li id="menu-item-307806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307806"><a href="https://tellymix.co.uk/tag/the-circle">The Circle</a></li>
<li id="menu-item-573744" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573744"><a href="https://tellymix.co.uk/tag/britains-got-talent">Britain&#39;s Got Talent</a></li>
<li id="menu-item-573747" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573747"><a href="https://tellymix.co.uk/tag/celebs-go-dating">Celebs Go Dating</a></li>
<li id="menu-item-573749" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573749"><a href="https://tellymix.co.uk/tag/the-x-factor">The X Factor</a></li>
<li><a href="/soaps">Soaps</a></li>
<li><a href="/ratings">TV Ratings</a></li>
</ul>
</div>
<div id="container" class="">
<header>
<div class="becky-width">
<div class="site-name"><a href="/"><span class="te">telly</span><span class="mi">mix</span></a></div>
<nav id="top-nav">
<ul>
<li id="mobile-menu-switch">
<a id="mobile-menu" href="javascript:void(0);">Menu</a></li>
<li class="becky-responsive-hide"><a href="/tv-news">TV News</a></li>
<li class="becky-responsive-hide"><a href="/tag/strictly-come-dancing">Strictly Come Dancing</a></li>
<li class="becky-responsive-hide"><a href="/tag/im-a-celebrity">I&#39;m A Celebrity</a></li>
<li class="becky-responsive-hide"><a href="/streaming">Streaming</a></li>

<li class="becky-responsive-hide all-links-controller"><a href="//tellymix.co.uk/#all-shows">More »</a>
</li>
<li class="becky-responsive-hide navsearch">
<form method="get" target="_top" action="https://tellymix.co.uk/">
<div>
<input type="text" placeholder="Search..." name="s" size="15" id="ns2" />
</div>
</form>
</li>
<li class="becky-responsive-hide nav-social" style="float:right;"><a href="https://twitter.com/intent/follow?screen_name=tellymix"> <svg class="twitter" fill="#fff" height="20" viewBox="0 0 24 24" width="20" xmlns="http://www.w3.org/2000/svg"><path d="M22.46,6C21.69,6.35 20.86,6.58 20,6.69C20.88,6.16 21.56,5.32 21.88,4.31C21.05,4.81 20.13,5.16 19.16,5.36C18.37,4.5 17.26,4 16,4C13.65,4 11.73,5.92 11.73,8.29C11.73,8.63 11.77,8.96 11.84,9.27C8.28,9.09 5.11,7.38 3,4.79C2.63,5.42 2.42,6.16 2.42,6.94C2.42,8.43 3.17,9.75 4.33,10.5C3.62,10.5 2.96,10.3 2.38,10C2.38,10 2.38,10 2.38,10.03C2.38,12.11 3.86,13.85 5.82,14.24C5.46,14.34 5.08,14.39 4.69,14.39C4.42,14.39 4.15,14.36 3.89,14.31C4.43,16 6,17.26 7.89,17.29C6.43,18.45 4.58,19.13 2.56,19.13C2.22,19.13 1.88,19.11 1.54,19.07C3.44,20.29 5.7,21 8.12,21C16,21 20.33,14.46 20.33,8.79C20.33,8.6 20.33,8.42 20.32,8.23C21.16,7.63 21.88,6.87 22.46,6Z"></path></svg></a></li>
<li class="becky-responsive-hide nav-social" style="float:right;"><a href="http://instagram.com/tellymix"><svg class="instagram" fill="#fff" height="20" viewBox="0 0 24 24" width="20" xmlns="http://www.w3.org/2000/svg"><path d="M7.8,2H16.2C19.4,2 22,4.6 22,7.8V16.2A5.8,5.8 0 0,1 16.2,22H7.8C4.6,22 2,19.4 2,16.2V7.8A5.8,5.8 0 0,1 7.8,2M7.6,4A3.6,3.6 0 0,0 4,7.6V16.4C4,18.39 5.61,20 7.6,20H16.4A3.6,3.6 0 0,0 20,16.4V7.6C20,5.61 18.39,4 16.4,4H7.6M17.25,5.5A1.25,1.25 0 0,1 18.5,6.75A1.25,1.25 0 0,1 17.25,8A1.25,1.25 0 0,1 16,6.75A1.25,1.25 0 0,1 17.25,5.5M12,7A5,5 0 0,1 17,12A5,5 0 0,1 12,17A5,5 0 0,1 7,12A5,5 0 0,1 12,7M12,9A3,3 0 0,0 9,12A3,3 0 0,0 12,15A3,3 0 0,0 15,12A3,3 0 0,0 12,9Z"></path></svg>
</a></li>
<li class="becky-responsive-hide nav-social" style="float:right;"><a href="http://facebook.com/tellymix"><svg class="facebook" xmlns="http://www.w3.org/2000/svg" fill="#fff" width="20" height="20" viewBox="15.8 15.8 25 25"><path d="M32.8 24.7h-3.2v-2.1c0-0.8 0.5-1 0.9-1s2.3 0 2.3 0v-3.5l-3.1 0c-3.5 0-4.3 2.6-4.3 4.3v2.3h-2v3.6h2c0 4.6 0 10.2 0 10.2h4.2c0 0 0-5.6 0-10.2h2.8L32.8 24.7z"></path></svg>
</a></li>
<li class="becky-responsive-hide nav-social" style="float:right;"><a href="http://youtube.com/tellymixcouk?sub_confirmation=1"> <svg class="youtube" fill="#fff" height="20" viewBox="0 0 24 24" width="20" xmlns="http://www.w3.org/2000/svg"><path d="M10,16.5V7.5L16,12M20,4.4C19.4,4.2 15.7,4 12,4C8.3,4 4.6,4.19 4,4.38C2.44,4.9 2,8.4 2,12C2,15.59 2.44,19.1 4,19.61C4.6,19.81 8.3,20 12,20C15.7,20 19.4,19.81 20,19.61C21.56,19.1 22,15.59 22,12C22,8.4 21.56,4.91 20,4.4Z"></path></svg>
</a></li>
</ul>
<div class="clear"></div>
</nav>
</div>
<div class="clear"></div>
</header>
<nav id="all-links" style="display:none;">
<div class="becky-width">
<a href="/tag/great-british-bake-off">Great British Bake Off</a>
<a href="/tag/the-voice-uk">The Voice UK</a>

<a href="/tag/the-masked-singer">The Masked Singer</a>
<a href="/tag/britains-got-talent">Britain&#39;s Got Talent</a>
<a href="/tag/dancing-on-ice">Dancing On Ice</a>
<a href="/tag/im-a-celebrity">I&#39;m A Celebrity</a>
<a href="/tag/celebs-go-dating">Celebs Go Dating</a>
<a href="/tag/love-island">Love Island</a>
<a href="/tag/the-x-factor">X Factor</a>
<a href="/tag/the-apprentice">The Apprentice</a>
<a href="/tag/big-brother">Big Brother</a>
<a href="/tag/the-masked-dancer">The Masked Dancer</a>
<a href="/tag/the-island">The Island</a>
<a href="/tag/disney">Disney+</a>
<a href="/tag/netflix">Netflix</a>
<a href="/tag/made-in-chelsea">Made In Chelsea</a>
<a href="/tag/the-only-way-is-essex">The Only Way Is Essex</a>
<a href="/tag/eurovision">Eurovision</a>
<a href="/ratings">TV Ratings</a>
</div>
</nav> <div id="body" class="becky-width">
<style type="text/css">
.adb_l88db { padding-top:0; display: none;}
             .usfsd9id9g, .ffsfgh { display: none; }
    .adb_l88db .a-text { padding-bottom: 9px; display: none;}
             
             
             @media (max-width: 970px) { .usfsd9id9g, .ffsfgh { height: 90px; } .adb_l88db .a-text, .adb_l88db, .usfsd9id9g, .ffsfgh { display: block;} }
             @media (max-width: 728px) { .usfsd9id9g, .ffsfgh { height: 100px; } }
             @media (max-width: 400px) { .usfsd9id9g, .ffsfgh { height: 100px; } }
             
</style>
<div class="adb_top adb_l88db">
<span class="a-text">
Advertisements</span>
<div class="ffsfgh">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle usfsd9id9g" data-ad-client="ca-pub-7416743337323842" data-ad-slot="3701568256" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>

<div class="post-599048 post type-post status-publish format-standard has-post-thumbnail hentry category-tv tag-doctor-who tag-its-a-sin tag-omari-douglas" id="post-599048">
<div class="single-article-header">
<nav id="bc" class="becky-responsive-hide"><p id="breadcrumbs"><a href="https://tellymix.co.uk">TellyMix</a> / <a href="https://tellymix.co.uk/tv-news">News</a> / <a href="https://tellymix.co.uk/tv" rel="category tag">TV</a> / <a href="https://tellymix.co.uk/tag/doctor-who">Doctor Who</a> /</p><script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "BreadcrumbList",
      "itemListElement": [ {
            "@type": "ListItem",
            "position": 1,
            "item": {
              "@id": "https://tellymix.co.uk",
              "name": "TellyMix"
            }
          },{
            "@type": "ListItem",
            "position": 2,
            "item": {
              "@id": "https://tellymix.co.uk/tv-news",
              "name": "News"
            }
          },{
            "@type": "ListItem",
            "position": 3,
            "item": {
              "@id": "https://tellymix.co.uk/tv",
              "name": "TV"
            }
          },{
            "@type": "ListItem",
            "position": 4,
            "item": {
              "@id": "https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html",
              "name": "It&#039;s A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who"
            }
          }]
    }
    </script></nav>
<h1 class="entry-title post-title"><a href="https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html" title="It&#39;s A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who">It&#39;s A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who</a></h1>
<div class="article-info">Posted <span class="published updated"><time datetime="2021-11-03T17:51:17+00:00">November 3, 2021 17:51</time></span> by <span class="vcard author author_name"><span class="fn">
<a class="url" href="https://tellymix.co.uk/author/annaleigh">Annaleigh Rose Clarke</a>
</span>
</span>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html"
  },
  "headline": "It&#039;s A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who",
  "image": [
    "https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?fit=1200%2C675&ssl=1"
   ],
  "datePublished": "2021-11-03T17:51:17+00:00",
  "dateModified": "2021-11-03T17:51:17+00:00",
  "author": {
    "@type": "Person",
    "name": "Annaleigh Rose Clarke"
  },
   "publisher": {
    "@type": "Organization",
    "name": "TellyMix",
    "logo": {
      "@type": "ImageObject",
       "url": "https://tellymix.co.uk/wp-content/uploads/2021/01/tellymix-logo.png",
        "height": 59,
        "width":  243
    }
  }
 
}
</script>
</div>
</div>
<section id="content" class="single-article">
<div id="inner-content">
<article id="single">
<div class="bpfs">
<img width="900" height="506" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20900%20506&#39;%3E%3C/svg%3E" class="attachment-article-image size-article-image" alt="Omari Douglas" data-lazy-srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 970px) 100vw, (max-width: 1018px) 600px, (max-width: 1250px) 768px, 900px" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?fit=900%2C506&amp;ssl=1" /><noscript><img width="900" height="506" src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?fit=900%2C506&amp;ssl=1" class="attachment-article-image size-article-image" alt="Omari Douglas" srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 970px) 100vw, (max-width: 1018px) 600px, (max-width: 1250px) 768px, 900px" /></noscript>
</div>
<div class="bsc">
<div class="dsl">
<a href="https://twitter.com/share?url=https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html&amp;text=It%27s+A+Sin+star+Omari+Douglas+tipped+to+replace+Jodie+Whittaker+on+Doctor+Who&amp;via=tellymix" target="_blank" rel="nofollow noopener" class="sbb sbb-twitter">Share on Twitter</a>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html" target="_blank" rel="nofollow noopener" class="sbb sbb-fbk">Share on Facebook</a>
<div class="clear"></div>
</div>

<p class="lead"><a target="_blank" href="https://tellymix.co.uk/tag/its-a-sin"><strong>It&#39;s A Sin</strong></a> star Omari Douglas has been tipped to takeover from Jodie Whittaker on <a target="_blank" href="https://tellymix.co.uk/tag/doctor-who"><strong>Doctor Who</strong></a>.</p>
<p><span id="more-599048"></span></p>
<p>It was confirmed recently that <a target="_blank" href="https://tellymix.co.uk/tv/519177-jodie-whittaker-to-leave-doctor-who-at-the-end-of-next-series.html">Jodie is to step down from Doctor Who after specials in 2022</a>.</p><div class="adb_top">
<span class="a-text">
Advertisements</span>
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7416743337323842" data-ad-slot="8908380993"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>There&#39;s been no shortage of speculation on who could be the next Doctor, and now there&#39;s a new name in the mix.</p>
<p>The Sun newspaper reports that star of <a target="_blank" href="https://tellymix.co.uk/tag/channel-4"><strong>Channel 4</strong></a> drama It&#39;s A Sin Omari Douglas is a &#34;frontrunner&#34; to takeover from Jodie in the role.</p>
<p>It follows the BBC announcing that It&#39;s A Sin writer and creator <a target="_blank" href="https://tellymix.co.uk/tv/595545-russell-t-davies-to-return-as-doctor-who-showrunner-from-2023.html">Russell T Davies will return to helm Doctor Who from 2023</a>.</p>
<p>&#34;Omari is the perfect candidate on so many levels, including the fact that the BBC said they’d prefer the Doctor to be played by a non-white actor,&#34; a source <a rel="noopener" href="https://www.thesun.co.uk/tv/16614131/doctor-who-omari-douglas-frontrunner-replace-jodie-whittaker/" target="_blank">told the newspaper</a>. &#34;He has also struck up the kind of close working relationship with Russell that helped Christopher and David get the sought after role.</p>
<p>&#34;And although he’s not quite a household name yet, he’s proved he&#39;s a great actor with a memorable performance in It’s a Sin.&#34;</p>
<p>As yet the BBC has not made any official announcements on who will be taking over the role from Jodie.</p>
<div class="adb_top">
<span class="a-text">
Advertisements</span>
<div style="height:280px; text-align:center;">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7416743337323842" data-ad-slot="5161919157" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<p>She and current showrunner Chris Chibnall will both leave Doctor Who in a trio of Specials which will air throughout 2022.</p>
<p>Previously responsible for Doctor Who’s revival in 2005, Russell T Davies is credited with propelling the show into a global phenomenon and making it one of TV’s biggest hits.</p>
<p>He said: &#34;I’m beyond excited to be back on my favourite show.</p>
<p>&#34;But we’re time-travelling too fast, there’s a whole series of Jodie Whittaker’s brilliant Doctor for me to enjoy, with my friend and hero Chris Chibnall at the helm - I’m still a viewer for now.&#34;</p>
<p>Doctor Who&#39;s 13th series currently airs Sunday nights on BBC One.</p>
<p>Titled Doctor Who: Flux, the new series tells one story across a vast canvas of six episodes. Mandip Gill, John Bishop and Jacob Anderson join Jodie on the cast.</p>
<div class="adb_top">
<span class="a-text">
Advertisements</span>
<script class="__lxGc__" type="text/javascript">
((__lxGc__=window.__lxGc__||{'s':{},'b':0})['s']['_194647']=__lxGc__['s']['_194647']||{'b':{}})['b']['_607873']={'i':__lxGc__.b++};
</script>
</div>
<p>You can catch up and watch episodes online now via <a rel="noopener" href="https://www.bbc.co.uk/iplayer/episodes/b006q2x0/doctor-who?seriesId=m00116r6" target="_blank">BBC iPlayer here</a>.</p>
<p>Picture: Omari Douglas in Channel 4&#39;s It&#39;s A Sin</p>
<div id="rcjsload_15438f"></div>
<script type="text/javascript">
(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "https://trends.revcontent.com/serve.js.php?w=9887&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
var rcds = document.getElementById("rcjsload_15438f"); rcds.appendChild(rcel);
})();
</script>
<div class="clear becky-single-end-more-box">
<strong>More on:</strong>
<a href="https://tellymix.co.uk/tag/doctor-who" rel="tag">Doctor Who</a> <a href="https://tellymix.co.uk/tag/its-a-sin" rel="tag">It&#39;s A Sin</a> <a href="https://tellymix.co.uk/tag/omari-douglas" rel="tag">Omari Douglas</a> <a href="https://tellymix.co.uk/tv" rel="category tag">TV</a> </div>
<div class="dsl">
<a href="https://twitter.com/share?url=https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html&amp;text=It%27s+A+Sin+star+Omari+Douglas+tipped+to+replace+Jodie+Whittaker+on+Doctor+Who&amp;via=tellymix" target="_blank" rel="nofollow noopener" class="sbb sbb-twitter">Share on Twitter</a>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html" target="_blank" rel="nofollow noopener" class="sbb sbb-fbk">Share on Facebook</a>
<div class="clear"></div>
</div>
<div class="clear"></div>
</div>
</article>
<div class="becky-social-post-article clr">
<div class="bsbb bsbb-twitter becky-responsive-hide">
<h5>Follow on <span>Twitter</span></h5>
<a rel="nofollow noopener" target="_blank" class="twitter-cat-fbtn" href="https://twitter.com/intent/follow?screen_name=tellymix">Follow @tellymix</a> </div>
<div class="bsbb bsbb-twitter becky-responsive-show">
<h5>Follow on <span>Twitter</span></h5>
<a rel="nofollow noopener" target="_blank" class="twitter-cat-fbtn" href="https://twitter.com/intent/follow?screen_name=tellymix">Follow @tellymix</a> </div>
<div class="bsbb bsbb-fbk"><h5>Like on <span>Facebook</span></h5>
<a rel="nofollow noopener" class="twitter-cat-fbtn fbk-cat-fbtn" target="_blank" href="https://facebook.com/tellymix">Like @tellymix</a></div>
<div class="clear"></div> </div>
</div>
</section>
</div>


<aside id="sidebar">
<style type="text/css">

             .sldbdd { display: block; height: 600px; }
    .ak-text { padding-bottom: 9px;}
             
             @media (max-width: 970px) { .sldbdd, .ak-text { display: none; } }
             
</style>
<span class="a-text ak-text">
Advertisements</span>
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle sldbdd" data-ad-client="ca-pub-7416743337323842" data-ad-slot="5018438481" data-ad-format="vertical" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<br /><br />




<div class="sidebar-box">
<h3>popular now</h3>
<ul>
<li>
<a href="https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="Omari Douglas" data-lazy-srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="Omari Douglas" srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>It&#39;s A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/tv/599002-an-audience-with-adele-concert-at-london-palladium-to-air-on-itv.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="Adele image credit - Simon Emmett" data-lazy-srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?w=2000&amp;ssl=1 2000w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=900%2C506&amp;ssl=1 900w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=500%2C281&amp;ssl=1 500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="Adele image credit - Simon Emmett" srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?w=2000&amp;ssl=1 2000w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=900%2C506&amp;ssl=1 900w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=500%2C281&amp;ssl=1 500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Adele-image-credit-Simon-Emmett.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>An Audience With Adele concert at London Palladium to air on ITV</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/reality-tv/473408-im-a-celebrity-2021-start-date-tv.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="I&#39;m A Celebrity 2021 logo" data-lazy-srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?w=2400&amp;ssl=1 2400w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=2000%2C1125&amp;ssl=1 2000w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="I&#039;m A Celebrity 2021 logo" srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?w=2400&amp;ssl=1 2400w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=2000%2C1125&amp;ssl=1 2000w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/im-a-celebrity-logo.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>I&#39;m A Celebrity 2021 start date revealed as show returns to Wales</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/reality-tv/598991-strictly-come-dancing-2021-spoilers-week-7-songs-and-dances-revealed.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="strictly come dancing group 4" data-lazy-srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?w=1920&amp;ssl=1 1920w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="strictly come dancing group 4" srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?w=1920&amp;ssl=1 1920w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/09/strictly-come-dancing-group-4.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Strictly Come Dancing 2021 spoilers! Week 7 songs and dances revealed</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/reality-tv/598741-strictly-come-dancing-2021-results-who-left-fifth-celebrity-voted-off.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="Katya Jones, Adam Peaty, Judi Love, Graziano Di Prima - (C) BBC - Photographer: Kieron McCarron" data-lazy-srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?w=2000&amp;ssl=1 2000w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=900%2C506&amp;ssl=1 900w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=500%2C281&amp;ssl=1 500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="Katya Jones, Adam Peaty, Judi Love, Graziano Di Prima - (C) BBC - Photographer: Kieron McCarron" srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?w=2000&amp;ssl=1 2000w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=900%2C506&amp;ssl=1 900w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=500%2C281&amp;ssl=1 500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23481747-low-.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Strictly Come Dancing results! Fifth celebrity voted off</span>
<div class="clear"></div>
</a>
</li>
</ul>
</div>

<div class="sidebar-aaa" style="margin-bottom: 25px;">
</div>
<div class="sidebar-related-posts sidebar-related-posts-wrapper">



<div class="sidebar-box">
<h3>latest news</h3>
<ul>
<li>
<a href="https://tellymix.co.uk/tv/599048-its-a-sin-star-omari-douglas-tipped-to-replace-jodie-whittaker-on-doctor-who.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="Omari Douglas" data-lazy-srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="Omari Douglas" srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Omari-Douglas.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>It&#39;s A Sin star Omari Douglas tipped to replace Jodie Whittaker on Doctor Who</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/tv/586811-craig-charles-to-host-new-channel-4-game-show-moneybags-apply-now.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="moneybags" data-lazy-srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="moneybags" srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/moneybags.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Moneybags: Craig Charles to host new Channel 4 game show</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/reality-tv/599035-strictly-come-dancings-adam-peaty-speaks-out-after-unexpected-dance-off.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="Katya Jones, Adam Peaty - (C) BBC - Photographer: Guy Levy" data-lazy-srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?zoom=3&amp;resize=160%2C90&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="Katya Jones, Adam Peaty - (C) BBC - Photographer: Guy Levy" srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/10/23265742-high-.jpg?zoom=3&amp;resize=160%2C90&amp;ssl=1 480w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Strictly Come Dancing&#39;s Adam Peaty speaks out after &#39;unexpected&#39; dance off</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/tv/599037-sex-and-the-city-reboot-and-just-like-that-to-air-on-sky-and-now-in-uk-from-december.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="And Just Like That" data-lazy-srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="And Just Like That" srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/And-Just-Like-That.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Sex and the City reboot And Just Like That... to air on Sky and NOW in UK from December</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/tv/599031-first-look-at-itvs-new-tom-jones-drama-as-hannah-waddingham-joins-cast.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="Tom Jones first look image" data-lazy-srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?w=2000&amp;ssl=1 2000w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="Tom Jones first look image" srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?w=2000&amp;ssl=1 2000w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/11/Tom-Jones-first-look-image-2000px.jpeg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>First look at ITV&#39;s new Tom Jones drama as Hannah Waddingham joins cast</span>
<div class="clear"></div>
</a>
</li>
</ul>
</div>
</div>
<div class="adb_top">
<span class="a-text">
Advertisements</span>
<script class="__lxGc__" type="text/javascript">
((__lxGc__=window.__lxGc__||{'s':{},'b':0})['s']['_194647']=__lxGc__['s']['_194647']||{'b':{}})['b']['_604220']={'i':__lxGc__.b++};
</script>
</div>
</aside>
<div class="clear"></div>
</div> 
<footer>

<div class="footer-content">
<div class="becky-width clr" style="text-align:center;">
<p>
<a href="/">Home</a>    
<a href="/about">About us</a>    
<a href="/about/writers">Meet the team</a>    
<a href="/contact">Contact</a>    
<a href="/about/privacy-and-cookies-policy">Privacy &amp; Cookies policy</a>    
<a href="#" onclick="if(window.__lxG__consent__ !== undefined) {window.__lxG__consent__.showConsent()} else {alert(&#39;This function only for users from European Economic Area (EEA)&#39;)}; return false">Privacy Settings / Opt out</a>
</p>
<p>© 2021. All Rights Reserved TellyMix unless otherwise stated. </p>
</div>
</div>
 </footer>
</div> 

<script type="text/javascript">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</script>
<meta name="twitter:widgets:autoload" content="off" />

<script>

    
    
    
jQuery(document).ready(function() {
	
	var panel = jQuery("#mobile-sidebar");

	jQuery("#mobile-menu").click(function() {
		if(panel.css("display") == "none") {
			panel.show();
		} else { panel.hide(); }
	});

	jQuery("#close-menu").click(function() { panel.hide(); });

		

});
</script>

<script type="text/javascript">var _merchantSettings=_merchantSettings || [];_merchantSettings.push(['AT', '10lt4w']);(function(){var autolink=document.createElement('script');autolink.type='text/javascript';autolink.async=true; autolink.src= ('https:' == document.location.protocol) ? 'https://autolinkmaker.itunes.apple.com/js/itunes_autolinkmaker.js' : 'http://autolinkmaker.itunes.apple.com/js/itunes_autolinkmaker.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(autolink, s);})();</script>
<script type="text/javascript" defer="" src="https://s.skimresources.com/js/6380X656712.skimlinks.js"></script>
<script type="text/javascript">
jQuery(document).ready(function() {
	
	var submenus = jQuery(".all-links-controller");

	submenus.click(function() {
		var submenu = jQuery("#all-links");

		submenu.slideToggle(400);
	return false;
	});



});
</script>

<script type="text/javascript" src="https://c0.wp.com/p/jetpack/10.0/_inc/build/photon/photon.min.js" id="jetpack-photon-js" defer=""></script>
<script src="https://stats.wp.com/e-202144.js" defer=""></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.0',blog:'11844673',post:'599048',tz:'0',srv:'tellymix.co.uk'} ]);
	_stq.push([ 'clickTrackerInit', '11844673', '599048' ]);
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async="" src="https://tellymix.co.uk/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script>
</body></html>