
<!DOCTYPE html><html lang="en"><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#"><meta charset="utf-8"><title>Michelle Keegan hints at a potential return to Our Girl | TV | TellyMix</title><link rel="icon" href="/favicon.ico" type="image/x-icon" /><link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" /><link rel="apple-touch-icon" href="/icon.png" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><meta name="description" content="Actress Michelle Keegan has hinted she could well return to Our Girl. The former Coronation Street star recently announced that after four years. Michelle" /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html" /><meta property="og:locale" content="en_GB" /><meta property="og:type" content="article" /><meta property="og:title" content="Michelle Keegan hints at a potential return to Our Girl" /><meta property="og:description" content="Left after four series" /><meta property="og:url" content="https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html" /><meta property="og:site_name" content="TellyMix" /><meta property="article:publisher" content="http://facebook.com/tellymix" /><meta property="article:author" content="http://facebook.com/spykajd" /><meta property="article:tag" content="Michelle Keegan" /><meta property="article:tag" content="Our Girl" /><meta property="article:section" content="TV" /><meta property="article:published_time" content="2020-05-06T15:53:45+00:00" /><meta property="article:modified_time" content="2020-05-06T15:55:58+00:00" /><meta property="og:updated_time" content="2020-05-06T15:55:58+00:00" /><meta property="og:image" content="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/03/michelle-keegan-ig.jpg?fit=1200%2C675&#038;ssl=1" /><meta property="og:image:secure_url" content="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/03/michelle-keegan-ig.jpg?fit=1200%2C675&#038;ssl=1" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Left after four series" /><meta name="twitter:title" content="Michelle Keegan hints at a potential return to Our Girl" /><meta name="twitter:image" content="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/03/michelle-keegan-ig.jpg?fit=1200%2C675&#038;ssl=1" /><meta name="twitter:creator" content="@spykajd" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://tellymix.co.uk/#organization","name":"TellyMix","url":"https://tellymix.co.uk/","sameAs":["http://facebook.com/tellymix","http://instagram.com/tellymix","http://youtube.com/tellymixcouk"],"logo":{"@type":"ImageObject","@id":"https://tellymix.co.uk/#logo","inLanguage":"en-GB","url":"https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2019/04/tellymix-2019-logo-square.jpg?fit=2000%2C2000&ssl=1","width":2000,"height":2000,"caption":"TellyMix"},"image":{"@id":"https://tellymix.co.uk/#logo"}},{"@type":"WebSite","@id":"https://tellymix.co.uk/#website","url":"https://tellymix.co.uk/","name":"TellyMix","inLanguage":"en-GB","description":"Reality telly goodness","publisher":{"@id":"https://tellymix.co.uk/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://tellymix.co.uk/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html#primaryimage","inLanguage":"en-GB","url":"https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/03/michelle-keegan-ig.jpg?fit=1200%2C675&ssl=1","width":1200,"height":675,"caption":"michelle keegan ig"},{"@type":"WebPage","@id":"https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html#webpage","url":"https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html","name":"Michelle Keegan hints at a potential return to Our Girl | TV | TellyMix","isPartOf":{"@id":"https://tellymix.co.uk/#website"},"inLanguage":"en-GB","primaryImageOfPage":{"@id":"https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html#primaryimage"},"datePublished":"2020-05-06T15:53:45+00:00","dateModified":"2020-05-06T15:55:58+00:00","description":"Actress Michelle Keegan has hinted she could well return to Our Girl. The former Coronation Street star recently announced that after four years. Michelle","potentialAction":[{"@type":"ReadAction","target":["https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html"]}]},{"@type":"NewsArticle","@id":"https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html#article","isPartOf":{"@id":"https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html#webpage"},"author":{"@id":"https://tellymix.co.uk/#/schema/person/03de1df2908d632e3ae464f221a6a668"},"headline":"Michelle Keegan hints at a potential return to Our Girl","datePublished":"2020-05-06T15:53:45+00:00","dateModified":"2020-05-06T15:55:58+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html#webpage"},"publisher":{"@id":"https://tellymix.co.uk/#organization"},"image":{"@id":"https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html#primaryimage"},"keywords":"Michelle Keegan,Our Girl","articleSection":"TV","inLanguage":"en-GB","copyrightYear":"2020","copyrightHolder":{"@id":"https://tellymix.co.uk/#organization"}},{"@type":["Person"],"@id":"https://tellymix.co.uk/#/schema/person/03de1df2908d632e3ae464f221a6a668","name":"Josh Darvill","description":"Josh's is the editor of TellyMix having been writing and reviewing TV for almost a decade now. He's a reality TV expert and a huge fan of Big Brother.","sameAs":["http://facebook.com/spykajd","https://twitter.com/spykajd"]}]}</script> <link rel='dns-prefetch' href='//tellymix-spykawebgroup.netdna-ssl.com' /><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://tellymix.co.uk/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style><link rel='https://api.w.org/' href='https://tellymix.co.uk/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tellymix.co.uk/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tellymix.co.uk/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://wp.me/pNHl7-1R30' /><meta name="cl:image" content="https://tellymix.co.uk/wp-content/uploads/2020/03/michelle-keegan-ig-800x450.jpg" /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><style type='text/css'>img#wpstats{display:none}</style><link rel="amphtml" href="https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html?amp"><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript> <style>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</style><meta name="google-site-verification" content="zMfeaeis4_OBoy3NMgj_KUI-SF45iLK_DPK59SmYPnQ" /><meta name="msvalidate.01" content="D7822FBA592ED89AF5EB1836F67784FF" /><link href="https://plus.google.com/108558804266181771802" rel="publisher" /><meta property="fb:pages" content="347362787491" /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-20273164-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20273164-1');</script> <script async type="text/javascript" src="//s.clickiocdn.com/t/consent_194647.js"></script> <script type="text/javascript">function check_consent()
    {
        var Cookie = {
            set: function(name,value,days) {
                if (days) {
                    var date = new Date();
                    date.setTime(date.getTime()+(days*24*60*60*1000));
                    var expires = "; expires="+date.toGMTString();
                }
                else var expires = "";
                document.cookie = name+"="+value+expires+"; path=/";
            },
            read: function(name) {
                var nameEQ = name + "=";
                var ca = document.cookie.split(';');
                for(var i=0;i < ca.length;i++) {
                    var c = ca[i];
                    while (c.charAt(0)==' ') {
                        c = c.substring(1,c.length);
                    }
                    if (c.indexOf(nameEQ) === 0) {
                        return c.substring(nameEQ.length,c.length);
                    }
                }
                return null;
            },
            exists: function(name) {
                return (this.read(name) !== null);
            }
        };
        
        console.log("Called");
        var consent_value = Cookie.read("__lxG__consent__").charAt(0);
    console.log(consent_value);
        if(consent_value == 1) 
        {
            console.log("return true");
           return true;
        }
        
            console.log("return false");
        return false;
    }</script> <script>var Cookie = {
        set: function(name,value,days) {
            if (days) {
                var date = new Date();
                date.setTime(date.getTime()+(days*24*60*60*1000));
                var expires = "; expires="+date.toGMTString();
            }
            else var expires = "";
            document.cookie = name+"="+value+expires+"; path=/";
        },
        read: function(name) {
            var nameEQ = name + "=";
            var ca = document.cookie.split(';');
            for(var i=0;i < ca.length;i++) {
                var c = ca[i];
                while (c.charAt(0)==' ') {
                    c = c.substring(1,c.length);
                }
                if (c.indexOf(nameEQ) === 0) {
                    return c.substring(nameEQ.length,c.length);
                }
            }
            return null;
        },
        exists: function(name) {
            return (this.read(name) !== null);
        }
    };

    var	cookie_name	= "accepted_cookie_policy";	
    var	consent_name	= "accepted_gdpr_policy";	
    var	cookie_expire	= 1000;


    var	has_cookies	= Cookie.exists(cookie_name);
    var	has_consent	= Cookie.exists(consent_name);
    
    if(!has_consent)
    {
            (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds = 1;
    }</script> <script async type="text/javascript" src="//s.clickiocdn.com/t/pb194647.js"></script> <script async type="text/javascript" src="//s.clickiocdn.com/t/common_258.js"></script> </head><body> <style type="text/css">div.mpuslot{width:auto!important;height:auto!important}div.mpuslot-float-none{padding:0!important}</style><div id="cookie-bar" class="clr" style="display: none;"><div id="cookie-bar-inner"><div id="consent-bar" style="display: none;"> <strong>Privacy and Cookies Policy</strong><p>This website uses cookies to personalise yourexperience including personalising content and ads, to provide social media features and to analyse our traffic with third parties inline with our <a href="//tellymix.co.uk/about/privacy-and-cookies-policy" id="cookie-bar-link" target="_blank" rel="noopener">Privacy and Cookies policy</a>.<p style="text-align:center;"> <a href="#" class="cookie-bar-button cookie-bar-consent-button">Okay</a> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <a href="#" class="cookie-bar-button cookie-bar-settings-button">Settings</a></p></div><div id="options-bar" style="display: none;"> <strong>Privacy and Cookies Policy</strong><p>This website uses cookies to personalise yourexperience Our partners will collect data and use cookies for ad personalisation and measurement. <a href="//tellymix.co.uk/about/privacy-and-cookies-policy" target="_blank" rel="noopener">Learn how we and our partners collect and use data</a>.</p><p style="text-align:center;"> <a href="#" class="cookie-bar-button cookie-bar-accept-button">Accept</a> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <a href="#" class="cookie-bar-button cookie-bar-reject-button">Reject</a></p></div><div id="cookies-bar" style="display: none;"> <strong>Privacy and Cookies Policy</strong><p>Okay. Please note that our site will still use cookies but not storing any personal data. <a href="//tellymix.co.uk/about/privacy-and-cookies-policy" id="cookie-bar-link-2" target="_blank" rel="noopener">Privacy and Cookies policy</a></p><p style="text-align:center;"> <a href="#" class="cookie-bar-button cookie-bar-okay-button">Okay!</a></p></div></div></div><div id="mobile-sidebar" class="no-amp-sidebar"><ul><li class="menu-spacer">TellyMix</li><li class="close-menu-button"> <button on="tap:mobile-sidebar.close" role="button" id="close-menu" tabindex="0">Close Menu</button></li><li><a href="/">Home</a></li><li><a href="/tv-news">All TV News</a></li><li id="menu-item-207102" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-207102"><a href="https://tellymix.co.uk/reality-tv/britains-got-talent">Britain's Got Talent</a></li><li id="menu-item-344997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-344997"><a href="https://tellymix.co.uk/reality-tv/the-voice">The Voice UK</a></li><li id="menu-item-261514" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261514"><a href="https://tellymix.co.uk/reality-tv/love-island">Love Island</a></li><li id="menu-item-219298" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-219298"><a href="https://tellymix.co.uk/reality-tv/strictly-come-dancing">Strictly Come Dancing</a></li><li id="menu-item-302995" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-302995"><a href="https://tellymix.co.uk/reality-tv/great-british-bake-off">Great British Bake Off</a></li><li id="menu-item-428525" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-428525"><a href="https://tellymix.co.uk/tag/the-masked-singer">The Masked Singer</a></li><li id="menu-item-344996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-344996"><a href="https://tellymix.co.uk/reality-tv/dancing-on-ice">Dancing On Ice</a></li><li id="menu-item-388694" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-388694"><a href="https://tellymix.co.uk/reality-tv/the-greatest-dancer">The Greatest Dancer</a></li><li id="menu-item-228020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-228020"><a href="https://tellymix.co.uk/reality-tv/the-x-factor">X Factor</a></li><li id="menu-item-219300" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-219300"><a href="https://tellymix.co.uk/reality-tv/im-a-celebrity">I'm A Celebrity</a></li><li id="menu-item-180660" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180660"><a href="https://tellymix.co.uk/reality-tv/the-apprentice">The Apprentice</a></li><li id="menu-item-307806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307806"><a href="https://tellymix.co.uk/reality-tv/the-circle">The Circle</a></li><li id="menu-item-302994" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-302994"><a href="https://tellymix.co.uk/reality-tv/celebs-go-dating">Celebs Go Dating</a></li><li id="menu-item-189674" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-189674"><a href="https://tellymix.co.uk/reality-tv/made-in-chelsea">Made In Chelsea</a></li><li><a href="/soaps">Soaps</a></li><li><a href="/ratings">TV Ratings</a></li><li class="navsearch noborderright"><form method="get" action="//tellymix.co.uk/"><div> <input type="text" placeholder="Search..." name="s" id="ns" /></div></form></li></ul></div><div id="container" class=""><header><div class="becky-width"><div class="site-name"><a href="/"><span class="te">telly</span><span class="mi">mix</span></a></div><nav id="top-nav"><ul><li id="mobile-menu-switch"> <a id="mobile-menu" href="javascript:void(0);">Menu</a></li><li class="becky-responsive-hide"><a href="/tv-news">News</a></li><li class="becky-responsive-hide"><a href="/reality-tv/britains-got-talent">Britain's Got Talent</a></li><li class="becky-responsive-hide"><a href="/reality-tv/the-voice">The Voice UK</a></li><li class="becky-responsive-hide"><a href="/reality-tv/love-island">Love Island</a></li><li class="becky-responsive-hide all-links-controller"><a href="//tellymix.co.uk/#all-shows">More &raquo;</a></li><li class="becky-responsive-hide navsearch"><form method="get" target="_top" action="https://tellymix.co.uk/"><div> <input type="text" placeholder="Search..." name="s" size="15" id="ns2" /></div></form></li></ul><div class="clear"></div></nav></div><div class="clear"></div></header><nav id="all-links" style="display:none;"><div class="becky-width"> <a href="/reality-tv/great-british-bake-off">Great British Bake Off</a> <a href="/reality-tv/dancing-on-ice">Dancing On Ice</a> <a href="https://tellymix.co.uk/tag/the-masked-singer">The Masked Singer</a> <a href="/reality-tv/strictly-come-dancing">Strictly Come Dancing</a> <a href="/reality-tv/the-x-factor">X Factor</a> <a href="/reality-tv/the-apprentice">The Apprentice</a> <a href="/reality-tv/celebs-go-dating">Celebs Go Dating</a> <a href="/reality-tv/the-island">The Island</a> <a href="/reality-tv/im-a-celebrity">I'm A Celebrity</a> <a href="/reality-tv/the-circle">The Circle</a> <a href="/reality-tv/big-brother">Big Brother</a> <a href="/reality-tv/made-in-chelsea">Made In Chelsea</a> <a href="/reality-tv/the-jump">The Jump</a> <a href="/reality-tv/the-only-way-is-essex">The Only Way Is Essex</a> <a href="/ratings">TV Ratings</a></div></nav><div id="body" class="becky-width"><style type="text/css">.adb_l88db{padding-top:0;display:none}.usfsd9id9g,.ffsfgh{display:none}.adb_l88db .a-text{padding-bottom:9px;display:none}@media (max-width:970px){.usfsd9id9g,.ffsfgh{height:90px}.adb_l88db .a-text,.adb_l88db,.usfsd9id9g,.ffsfgh{display:block}}@media (max-width:728px){.usfsd9id9g,.ffsfgh{height:100px}}@media (max-width:400px){.usfsd9id9g,.ffsfgh{height:50px}}</style><div class="adb_top adb_l88db"> <span class="a-text"> Advertisements</span><div class="ffsfgh"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle usfsd9id9g" data-ad-client="ca-pub-7416743337323842" data-ad-slot="3701568256" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div class="post-442246 post type-post status-publish format-standard has-post-thumbnail hentry category-tv tag-michelle-keegan tag-our-girl" id="post-442246"><div class="single-article-header"><nav id="bc" class="becky-responsive-hide"><p id='breadcrumbs'><a href="https://tellymix.co.uk">TellyMix</a> / <a href="https://tellymix.co.uk/tv-news">News</a> / <a href="https://tellymix.co.uk/tv" rel="category tag">TV</a> /</p><script type="application/ld+json">{
      "@context": "http://schema.org",
      "@type": "BreadcrumbList",
      "itemListElement": [ {
            "@type": "ListItem",
            "position": 1,
            "item": {
              "@id": "https://tellymix.co.uk",
              "name": "TellyMix"
            }
          },{
            "@type": "ListItem",
            "position": 2,
            "item": {
              "@id": "https://tellymix.co.uk/tv-news",
              "name": "News"
            }
          },{
            "@type": "ListItem",
            "position": 3,
            "item": {
              "@id": "https://tellymix.co.uk/tv",
              "name": "TV"
            }
          },{
            "@type": "ListItem",
            "position": 4,
            "item": {
              "@id": "https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html",
              "name": "Michelle Keegan hints at a potential return to Our Girl"
            }
          }]
    }</script></nav><h1 class="entry-title post-title"><a href="https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html" title="Michelle Keegan hints at a potential return to Our Girl">Michelle Keegan hints at a potential return to Our Girl</a></h1><div class="article-info">Posted <span class="published updated"><time datetime="2020-05-06T16:53:45+01:00">May 6, 2020 16:55</time></span> by <span class="vcard author author_name"><span class="fn"> <a class="url" href="https://tellymix.co.uk/author/joshdarvill">Josh Darvill</a> </span> </span> <script type="application/ld+json">{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html"
  },
  "headline": "Michelle Keegan hints at a potential return to Our Girl",
  "image": [
    "https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/03/michelle-keegan-ig.jpg?resize=1200%2C675&ssl=1"
   ],
  "datePublished": "2020-05-06T16:53:45+01:00",
  "dateModified": "2020-05-06T16:55:58+01:00",
  "author": {
    "@type": "Person",
    "name": "Josh Darvill"
  },
   "publisher": {
    "@type": "Organization",
    "name": "TellyMix",
    "logo": {
      "@type": "ImageObject",
       "url": "https://tellymix.co.uk/wp-content/uploads/2017/05/tellymix-amp-logo-v2.jpg",
        "height": 60,
        "width":  600
    }
  }
 
}</script> </div></div><section id="content" class="single-article"><div id="inner-content"><article id="single"><div class="becky-post-featured-spot"> <img width="800" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20800%20450'%3E%3C/svg%3E" height="450" layout="responsive" alt="michelle keegan ig" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/03/michelle-keegan-ig.jpg?resize=800%2C450&ssl=1" /><noscript><img width="800" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/03/michelle-keegan-ig.jpg?resize=800%2C450&ssl=1" height="450" layout="responsive" alt="michelle keegan ig" /></noscript></div><div class="becky-single-content"><div class="postmetadata-share-widgets"><div class="DaisyArticleShareLinks"> <a href="https://twitter.com/share?url=https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html&text=Michelle+Keegan+hints+at+a+potential+return+to+Our+Girl&via=tellymix" target="_blank" rel="nofollow noopener" class="share-button share-button-twitter">Share on Twitter</a> <a href="https://www.facebook.com/sharer/sharer.php?u=https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html" target="_blank" rel="nofollow noopener" class="share-button share-button-facebook">Share on Facebook</a><div class="clear"></div></div></div><p class="lead">Actress Michelle Keegan has hinted she could well return to <a target="_blank" href="https://tellymix.co.uk/tag/our-girl"><strong>Our Girl</strong></a>.</p><p><span id="more-442246"></span></p><p>The former <a target="_blank" href="https://tellymix.co.uk/soaps/coronation-street"><strong>Coronation Street</strong></a> star recently announced that <a target="_blank" href="https://tellymix.co.uk/tv/430229-michelle-keegan-to-leave-our-girl-cast-after-four-years.html" class="becky-al" rel="noopener">she was stepping down from her role on BBC One's Our Girl</a> after four years.</p><div class="adb_top"> <span class="a-text"> Advertisements</span> <script class='__lxGc__' type='text/javascript'>((__lxGc__=window.__lxGc__||{'s':{},'b':0})['s']['_194647']=__lxGc__['s']['_194647']||{'b':{}})['b']['_639935']={'i':__lxGc__.b++};</script> </div><p>Michelle has led the cast of the BBC series since 2016 but this year's fourth outing was her last - for now.</p><p>Appearing on The One Show, Michelle suggested that her exit from Our Girl as Georgie Lane wasn't necessarily permanent.</p><p>She said: "I've done four series altogether and I just thought Georgie deserved a bit of break. It was just for me to try and get other opportunities.</p><p>"I'm glad it's over now because now I can officially say, I can always come back. The door has been left open for Georgie. I absolutely love the show, I'm so proud of it. Hopefully you'll see Georgie again."</p><p>As for what's next, <a rel="nofollow noopener" href="http://www.thesun.co.uk/" target="_blank">The Sun newspaper</a> has reported that Michelle could be set for the Strictly ballroom in the autumn.</p><p>A source claimed: "Michelle ticks all the boxes. She's glamorous, hugely popular and loves the show too. Producers are desperate to try and sign her up.</p><div class="mpuslot mpuslot-float-left"><div class="adb_top"> <span class="a-text"> Advertisements</span> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <style type="text/css">.adslot_inarticlemiddle{display:inline-block;width:336px;height:280px}@media (min-width:576px){.adslot_inarticlemiddle{display:none}}</style> <ins class="adsbygoogle adslot_inarticlemiddle" style="width:336px;height:280px" data-ad-client="ca-pub-7416743337323842" data-full-width-responsive="true" data-ad-slot="4812485794"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><p>"They know that getting her to agree would be a massive coup and are hoping she will do it."</p><p>But one show Michelle has ruled herself out of is Celebrity Juice.</p><p>She had been rumoured as a possible replacement for Holly Willoughby on the ITV2 series after Holly announced her exit on Sunday after 12 years.</p><p>Michelle told The One Show: "I can officially say that's not true. Don't get me wrong, I'm a massive fan of the show. I love the show, I find it hilarious.</p><p>"But, at the minute, no, no, that's not true."</p><p><a target="_blank" href="https://tellymix.co.uk/reality-tv/strictly-come-dancing"><strong>Strictly Come Dancing</strong></a> airs on BBC One.</p><div class="adb_top"> <span class="a-text"> Advertisements</span> <script class='__lxGc__' type='text/javascript'>((__lxGc__=window.__lxGc__||{'s':{},'b':0})['s']['_194647']=__lxGc__['s']['_194647']||{'b':{}})['b']['_607873']={'i':__lxGc__.b++};</script> </div><p>The line up is usually confirmed from August with the show starting on TV in September.</p><p>PICTURE: Instagram/<a rel="nofollow noopener" href="https://www.instagram.com/michkeegan/?hl=en" target="_blank">@michkeegan</a></p><div id="rcjsload_15438f"></div> <script type="text/javascript">(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "https://trends.revcontent.com/serve.js.php?w=9887&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
var rcds = document.getElementById("rcjsload_15438f"); rcds.appendChild(rcel);
})();</script> <div class="clear becky-single-end-more-box"> <strong>More on:</strong> <a href="https://tellymix.co.uk/tag/michelle-keegan" rel="tag">Michelle Keegan</a> <a href="https://tellymix.co.uk/tag/our-girl" rel="tag">Our Girl</a> <a href="https://tellymix.co.uk/tv" rel="category tag">TV</a></div><div class="DaisyArticleShareLinks"> <a href="https://twitter.com/share?url=https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html&text=Michelle+Keegan+hints+at+a+potential+return+to+Our+Girl&via=tellymix" target="_blank" rel="nofollow noopener" class="share-button share-button-twitter">Share on Twitter</a> <a href="https://www.facebook.com/sharer/sharer.php?u=https://tellymix.co.uk/tv/442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html" target="_blank" rel="nofollow noopener" class="share-button share-button-facebook">Share on Facebook</a><div class="clear"></div></div><div class="clear"></div></div></article><div class="becky-social-post-article clr"><div class="becky-social becky-social-twitter becky-responsive-hide"><h5>Follow on <span>Twitter</span></h5> <a rel="nofollow noopener" target="_blank" class="twitter-cat-follow-button" href="https://twitter.com/intent/follow?screen_name=tellymix">Follow @tellymix</a></div><div class="becky-social becky-social-twitter becky-responsive-show"><h5>Follow on <span>Twitter</span></h5> <a rel="nofollow noopener" target="_blank" class="twitter-cat-follow-button" href="https://twitter.com/intent/follow?screen_name=tellymix">Follow @tellymix</a></div><div class="becky-social becky-social-facebook"><h5>Like on <span>Facebook</span></h5> <a rel="nofollow noopener" class="twitter-cat-follow-button facebook-cat-follow-button" target="_blank" href="https://facebook.com/tellymix">Like @tellymix</a></div><div class="clear"></div></div></div></section></div><aside id="sidebar"><style type="text/css">.sldbdd{display:block;height:280px}.ak-text{padding-bottom:9px}@media (max-width:970px){.sldbdd,.ak-text{display:none}}</style><span class="a-text ak-text"> Advertisements</span> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle sldbdd" data-ad-client="ca-pub-7416743337323842" data-ad-slot="5824673874" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> <br><br><div class="sidebar-box"><h3>what's hot</h3><ul><li><a href="https://tellymix.co.uk/reality-tv/big-brother/442275-big-brother-tipped-for-possible-return-after-love-island-cancellation.html"> <img width="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20160%2090'%3E%3C/svg%3E" height="90" layout="responsive" alt="big brother logo" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/05/big-brother-logo.jpg?resize=160%2C90&ssl=1" /><noscript><img width="160" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/05/big-brother-logo.jpg?resize=160%2C90&ssl=1" height="90" layout="responsive" alt="big brother logo" /></noscript> <span>Big Brother tipped for possible return after Love Island cancellation </span><div class="clear"></div> </a></li><li><a href="https://tellymix.co.uk/reality-tv/420554-sas-who-dares-wins-celebrity-contestants-line-up-2020.html"> <img width="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20160%2090'%3E%3C/svg%3E" height="90" layout="responsive" alt="sas who dares wins 2020 celebrity line up" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2020/04/sas-who-dares-wins-2020-celebrity-line-up.jpg?resize=160%2C90&ssl=1" /><noscript><img width="160" src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2020/04/sas-who-dares-wins-2020-celebrity-line-up.jpg?resize=160%2C90&ssl=1" height="90" layout="responsive" alt="sas who dares wins 2020 celebrity line up" /></noscript> <span>SAS: Who Dares Wins celebrity contestants line up 2020 confirmed</span><div class="clear"></div> </a></li><li><a href="https://tellymix.co.uk/reality-tv/love-island/437204-love-island-2020-cancelled.html"> <img width="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20160%2090'%3E%3C/svg%3E" height="90" layout="responsive" alt="love island logo" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/02/love-island-logo.jpg?resize=160%2C90&ssl=1" /><noscript><img width="160" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/02/love-island-logo.jpg?resize=160%2C90&ssl=1" height="90" layout="responsive" alt="love island logo" /></noscript> <span>Love Island 2020 cancelled as ITV confirm show will return in 2021</span><div class="clear"></div> </a></li><li><a href="https://tellymix.co.uk/reality-tv/great-british-bake-off/438029-great-british-bake-off-2020-could-be-cancelled.html"> <img width="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20160%2090'%3E%3C/svg%3E" height="90" layout="responsive" alt="Great British Bake Off logo" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2016/10/bake-off-title-logo.jpg?resize=160%2C90&ssl=1" /><noscript><img width="160" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2016/10/bake-off-title-logo.jpg?resize=160%2C90&ssl=1" height="90" layout="responsive" alt="Great British Bake Off logo" /></noscript> <span>Great British Bake Off 2020 'could be cancelled' due to lockdown restrictions</span><div class="clear"></div> </a></li><li><a href="https://tellymix.co.uk/reality-tv/britains-got-talent/441705-britains-got-talent-2020-recap-watch-all-of-the-auditions-from-week-four-online.html"> <img width="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20160%2090'%3E%3C/svg%3E" height="90" layout="responsive" alt="SOS From The Kids." data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/04/britains-got-talent-2020-contestants-week-4-3.jpg?resize=160%2C90&ssl=1" /><noscript><img width="160" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/04/britains-got-talent-2020-contestants-week-4-3.jpg?resize=160%2C90&ssl=1" height="90" layout="responsive" alt="SOS From The Kids." /></noscript> <span>Britain's Got Talent recap! All of the auditions from week four</span><div class="clear"></div> </a></li></ul></div><div class="sidebar-aaa" style="margin-bottom: 25px;"></div><div class="sidebar-related-posts sidebar-related-posts-wrapper"><div class="sidebar-box"><h3>just posted</h3><ul><li><a href="https://tellymix.co.uk/reality-tv/436308-ferne-mccann-first-time-mum-2020-series-6.html"> <img width="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20160%2090'%3E%3C/svg%3E" height="90" layout="responsive" alt="Ferne McCann series 4" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2019/10/Ferne-McCann-series-4.jpg?resize=160%2C90&ssl=1" /><noscript><img width="160" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2019/10/Ferne-McCann-series-4.jpg?resize=160%2C90&ssl=1" height="90" layout="responsive" alt="Ferne McCann series 4" /></noscript> <span>Ferne McCann: First Time Mum series 6 - show will return in the autumn!</span><div class="clear"></div> </a></li><li><a href="https://tellymix.co.uk/reality-tv/422322-watch-ferne-mccann-first-time-mum-online-and-catch-up-on-past-episodes-2020.html"> <img width="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20160%2090'%3E%3C/svg%3E" height="90" layout="responsive" alt="Ferne McCann series 4" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2019/10/Ferne-McCann-series-4.jpg?resize=160%2C90&ssl=1" /><noscript><img width="160" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2019/10/Ferne-McCann-series-4.jpg?resize=160%2C90&ssl=1" height="90" layout="responsive" alt="Ferne McCann series 4" /></noscript> <span>Watch Ferne McCann: First Time Mum online and catch up on past episodes</span><div class="clear"></div> </a></li><li><a href="https://tellymix.co.uk/tv/440995-the-great-british-sewing-bee-2020-contestants-results-spoilers-series-6.html"> <img width="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20160%2090'%3E%3C/svg%3E" height="90" layout="responsive" alt="The Great British Sewing Bee 2020 contestants" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/04/The-Great-British-Sewing-Bee-2020-contestants.jpg?resize=160%2C90&ssl=1" /><noscript><img width="160" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/04/The-Great-British-Sewing-Bee-2020-contestants.jpg?resize=160%2C90&ssl=1" height="90" layout="responsive" alt="The Great British Sewing Bee 2020 contestants" /></noscript> <span>The Great British Sewing Bee 2020 contestants and spoilers from series 6</span><div class="clear"></div> </a></li><li><a href="https://tellymix.co.uk/tv/441790-absolutely-india-mancs-in-mumbai-episodes-spoilers-and-how-to-watch-online.html"> <img width="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20160%2090'%3E%3C/svg%3E" height="90" layout="responsive" alt="Absolutely India Mancs in Mumbai" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/04/Absolutely-India-Mancs-in-Mumbai.jpg?resize=160%2C90&ssl=1" /><noscript><img width="160" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2020/04/Absolutely-India-Mancs-in-Mumbai.jpg?resize=160%2C90&ssl=1" height="90" layout="responsive" alt="Absolutely India Mancs in Mumbai" /></noscript> <span>Absolutely India: Mancs in Mumbai episodes, spoilers and how to watch online</span><div class="clear"></div> </a></li><li><a href="https://tellymix.co.uk/tv/442283-michael-mcintyre-to-look-back-at-the-best-moments-from-his-big-show-in-new-series.html"> <img width="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20160%2090'%3E%3C/svg%3E" height="90" layout="responsive" alt="michael mcintyre" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2019/11/michael-mcintyre.jpg?resize=160%2C90&ssl=1" /><noscript><img width="160" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2019/11/michael-mcintyre.jpg?resize=160%2C90&ssl=1" height="90" layout="responsive" alt="michael mcintyre" /></noscript> <span>Michael McIntyre to look back at the best moments from his Big Show in new series</span><div class="clear"></div> </a></li></ul></div></div><div class="adb_top"> <span class="a-text"> Advertisements</span> <script class='__lxGc__' type='text/javascript'>((__lxGc__=window.__lxGc__||{'s':{},'b':0})['s']['_194647']=__lxGc__['s']['_194647']||{'b':{}})['b']['_604220']={'i':__lxGc__.b++};</script> </div></aside><div class="clear"></div></div><footer><div class="footer-content"><div class="becky-width clr" style="text-align:center;"><ul><li><a href="/">Home</a></li><li><a href="/about">About us</a></li><li><a href="/about/writers">Meet the team</a></li><li><a href="/contact">Contact</a></li><li><a href="//tellymix.co.uk/about/privacy-and-cookies-policy">Privacy &amp; Cookies policy</a></li><li><a href="#" onclick="if(window.__lxG__consent__ !== undefined) {window.__lxG__consent__.showConsent()} else {alert('This function only for users from European Economic Area (EEA)')}; return false">Privacy Settings / Opt out</a></li></ul></div></div><div class="footer-bottom"><div class="becky-width"><p>&copy; 2020. All Rights Reserved TellyMix unless otherwise stated.</p></div></div></footer></div> <script type="text/javascript">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</script> <script>jQuery(document).ready(function() {
	
	var panel = jQuery("#mobile-sidebar");

	jQuery("#mobile-menu").click(function() {
		if(panel.css("display") == "none") {
			panel.show();
		} else { panel.hide(); }
	});

	jQuery("#close-menu").click(function() { panel.hide(); });


						

});</script> <script async type="text/javascript" src="https://spyka.co.uk/gl.php?f_l=l9d89&um=tellymix/%2Ftv%2F442246-michelle-keegan-hints-at-a-potential-return-to-our-girl.html"></script> <script type='text/javascript'>var _merchantSettings=_merchantSettings || [];_merchantSettings.push(['AT', '10lt4w']);(function(){var autolink=document.createElement('script');autolink.type='text/javascript';autolink.async=true; autolink.src= ('https:' == document.location.protocol) ? 'https://autolinkmaker.itunes.apple.com/js/itunes_autolinkmaker.js' : 'http://autolinkmaker.itunes.apple.com/js/itunes_autolinkmaker.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(autolink, s);})();</script> <script type="text/javascript" src="https://s.skimresources.com/js/6380X656712.skimlinks.js"></script> <script type="text/javascript">jQuery(document).ready(function() {
	
	var submenus = jQuery(".all-links-controller");

	submenus.click(function() {
		var submenu = jQuery("#all-links");

		submenu.slideToggle(400);
	return false;
	});



});</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.4.2/_inc/build/photon/photon.min.js'></script> <script type='text/javascript' src='https://stats.wp.com/e-202019.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.4.2',blog:'11844673',post:'442246',tz:'1',srv:'tellymix.co.uk'} ]);
	_stq.push([ 'clickTrackerInit', '11844673', '442246' ]);</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script type="text/javascript">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</script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script> </body></html>
