<!DOCTYPE html><html lang="en"><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<meta charset="utf-8" />

<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<style>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</style>


<title>Coronation Street spoilers: Steve McDonald punches Jacob Hay in explosive episode | Soaps | TellyMix</title>


<link rel="icon" href="/favicon.ico" type="image/x-icon" />
<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" href="/icon.png" />
<link rel="preconnect" href="//i0.wp.com" />
<link rel="preconnect" href="//i1.wp.com" />
<link rel="preconnect" href="//i2.wp.com" />
<link rel="preconnect" href="//c0.wp.com" />


<meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1" />

<meta name="description" content="Steve McDonald and Jacob Hay come to blows in tonight&#39;s episode of Coronation Street. In this evening&#39;s instalment of the ITV soap, Steve finally sees red" />
<link rel="canonical" href="https://tellymix.co.uk/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Corrie spoilers: Steve McDonald punches Jacob Hay in explosive episode" />
<meta property="og:description" content="After Amy&#39;s drink is spiked" />
<meta property="og:url" content="https://tellymix.co.uk/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html" />
<meta property="og:site_name" content="TellyMix" />
<meta property="article:publisher" content="http://facebook.com/tellymix" />
<meta property="article:author" content="http://facebook.com/spykajd" />
<meta property="article:published_time" content="2022-02-16T08:00:48+00:00" />
<meta property="article:modified_time" content="2022-02-16T06:37:53+00:00" />
<meta property="og:image" content="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?fit=2000%2C1125&amp;ssl=1" />
<meta property="og:image:width" content="2000" />
<meta property="og:image:height" content="1125" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Corrie spoilers: Steve McDonald punches Jacob Hay in explosive episode" />
<meta name="twitter:description" content="After Amy&#39;s drink is spiked" />
<meta name="twitter:creator" content="@spykajd" />
<meta name="twitter:site" content="@tellymix" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel="dns-prefetch" href="//c0.wp.com" />
<link rel="dns-prefetch" href="//i0.wp.com" />
<link rel="dns-prefetch" href="//i1.wp.com" />
<link rel="dns-prefetch" href="//i2.wp.com" />
<link rel="stylesheet" id="mediaelement-css" href="https://c0.wp.com/c/5.8.3/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css" type="text/css" media="all" />
<link rel="stylesheet" id="wp-mediaelement-css" href="https://c0.wp.com/c/5.8.3/wp-includes/js/mediaelement/wp-mediaelement.min.css" type="text/css" media="all" />
<style id="rocket-lazyload-inline-css" type="text/css">
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player:focus-within{outline: 2px solid currentColor;outline-offset: 5px;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:100%;width:100%;left:0;top:0;position:absolute;background:url(https://tellymix.co.uk/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat center;background-color: transparent !important;cursor:pointer;border:none;}
</style>
<link rel="https://api.w.org/" href="https://tellymix.co.uk/wp-json/" /><link rel="alternate" type="application/json" href="https://tellymix.co.uk/wp-json/wp/v2/posts/608896" /><link rel="alternate" type="application/json+oembed" href="https://tellymix.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftellymix.co.uk%2Fsoaps%2F608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html" />
<link rel="alternate" type="text/xml+oembed" href="https://tellymix.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftellymix.co.uk%2Fsoaps%2F608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html&amp;format=xml" />
<style type="text/css">img#wpstats{display:none}</style>
<link rel="amphtml" href="https://tellymix.co.uk/amp/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html" /><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>

<meta name="google-site-verification" content="zMfeaeis4_OBoy3NMgj_KUI-SF45iLK_DPK59SmYPnQ" />
<meta name="msvalidate.01" content="D7822FBA592ED89AF5EB1836F67784FF" />
<link href="https://plus.google.com/108558804266181771802" rel="publisher" />
<meta property="fb:pages" content="347362787491" />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />

<script async="" src="https://www.googletagmanager.com/gtag/js?id=UA-20273164-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20273164-1');
</script>
<script async="" type="text/javascript" src="//s.clickiocdn.com/t/consent_194647.js"></script>

<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-7416743337323842",
    enable_page_level_ads: true
  });
</script>
<script async="" type="text/javascript" src="//s.clickiocdn.com/t/194647/360_light.js"></script>
<link href="https://s.clickiocdn.com/t/static/prism_feed.min.css" rel="stylesheet" />
<script src="https://s.clickiocdn.com/t/static/prism_feed.min.js" defer=""></script>
<script async="" type="text/javascript" src="//s.clickiocdn.com/t/194647/360_light.js"></script>
<script>
        document.addEventListener("DOMContentLoaded", () => {
            if (typeof infiniteScroll !== "undefined") {
                new infiniteScroll({
                    element: ".bsc > p:last-of-type",
                    googleAnalyticsSettings: {
                        gaTrackingId: "UA-20273164-1",
                        gaType: "gtag"
                    },
                    maxScrollElements: 2
                });
            }
        });
</script>
</head>
<body>

<style type="text/css">div.mpuslot { width: auto !important; height: auto !important; }
div.mpuslot-float-none { padding:0 !important; } 
</style>

<div id="mobile-sidebar" class="no-amp-sidebar">
<ul>
<li class="menu-spacer">TellyMix</li>
<li class="close-menu-button"> <button on="tap:mobile-sidebar.close" role="button" id="close-menu" tabindex="0">Close Menu</button></li>
<li><a href="/">Home</a></li>
<li><a href="/tv-news">All TV News</a></li>
<li class="navsearch noborderright">
<form method="get" action="https://tellymix.co.uk/">
<div>
<input type="text" placeholder="Search..." name="s" id="ns" />
</div>
</form>
</li>
<li id="menu-item-573748" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573748"><a href="https://tellymix.co.uk/tag/love-island">Love Island</a></li>
<li id="menu-item-573745" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573745"><a href="https://tellymix.co.uk/tag/strictly-come-dancing">Strictly Come Dancing</a></li>
<li id="menu-item-573743" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573743"><a href="https://tellymix.co.uk/tag/great-british-bake-off">Great British Bake Off</a></li>
<li id="menu-item-573742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-573742"><a href="https://tellymix.co.uk/streaming">Streaming</a></li>
<li id="menu-item-573746" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573746"><a href="https://tellymix.co.uk/tag/im-a-celebrity">I&#39;m A Celebrity</a></li>
<li id="menu-item-578426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-578426"><a href="https://tellymix.co.uk/tag/the-voice-uk">The Voice UK</a></li>
<li id="menu-item-428525" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-428525"><a href="https://tellymix.co.uk/tag/the-masked-dancer">The Masked Dancer</a></li>
<li id="menu-item-578427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-578427"><a href="https://tellymix.co.uk/tag/dancing-on-ice">Dancing On Ice</a></li>
<li id="menu-item-307806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307806"><a href="https://tellymix.co.uk/tag/the-circle">The Circle</a></li>
<li id="menu-item-573744" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573744"><a href="https://tellymix.co.uk/tag/britains-got-talent">Britain&#39;s Got Talent</a></li>
<li id="menu-item-573747" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573747"><a href="https://tellymix.co.uk/tag/celebs-go-dating">Celebs Go Dating</a></li>
<li id="menu-item-573749" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573749"><a href="https://tellymix.co.uk/tag/the-x-factor">The X Factor</a></li>
<li><a href="/soaps">Soaps</a></li>
<li><a href="/ratings">TV Ratings</a></li>
</ul>
</div>
<div id="container" class="">
<header>
<div class="becky-width">
<div class="site-name"><a href="/"><span class="te">telly</span><span class="mi">mix</span></a></div>
<nav id="top-nav">
<ul>
<li id="mobile-menu-switch">
<a id="mobile-menu" href="javascript:void(0);">Menu</a></li>
<li class="becky-responsive-hide"><a href="/tv-news">TV News</a></li>
<li class="becky-responsive-hide"><a href="/tag/the-masked-singer">The Masked Singer</a></li>
<li class="becky-responsive-hide"><a href="/streaming">Streaming</a></li>

<li class="becky-responsive-hide all-links-controller"><a href="//tellymix.co.uk/#all-shows">More »</a>
</li>
<li class="becky-responsive-hide navsearch">
<form method="get" target="_top" action="https://tellymix.co.uk/">
<div>
<input type="text" placeholder="Search..." name="s" size="15" id="ns2" />
</div>
</form>
</li>
<li class="becky-responsive-hide nav-social" style="float:right;"><a href="https://twitter.com/intent/follow?screen_name=tellymix"> <svg class="twitter" fill="#fff" height="20" viewBox="0 0 24 24" width="20" xmlns="http://www.w3.org/2000/svg"><path d="M22.46,6C21.69,6.35 20.86,6.58 20,6.69C20.88,6.16 21.56,5.32 21.88,4.31C21.05,4.81 20.13,5.16 19.16,5.36C18.37,4.5 17.26,4 16,4C13.65,4 11.73,5.92 11.73,8.29C11.73,8.63 11.77,8.96 11.84,9.27C8.28,9.09 5.11,7.38 3,4.79C2.63,5.42 2.42,6.16 2.42,6.94C2.42,8.43 3.17,9.75 4.33,10.5C3.62,10.5 2.96,10.3 2.38,10C2.38,10 2.38,10 2.38,10.03C2.38,12.11 3.86,13.85 5.82,14.24C5.46,14.34 5.08,14.39 4.69,14.39C4.42,14.39 4.15,14.36 3.89,14.31C4.43,16 6,17.26 7.89,17.29C6.43,18.45 4.58,19.13 2.56,19.13C2.22,19.13 1.88,19.11 1.54,19.07C3.44,20.29 5.7,21 8.12,21C16,21 20.33,14.46 20.33,8.79C20.33,8.6 20.33,8.42 20.32,8.23C21.16,7.63 21.88,6.87 22.46,6Z"></path></svg></a></li>
<li class="becky-responsive-hide nav-social" style="float:right;"><a href="http://instagram.com/tellymix"><svg class="instagram" fill="#fff" height="20" viewBox="0 0 24 24" width="20" xmlns="http://www.w3.org/2000/svg"><path d="M7.8,2H16.2C19.4,2 22,4.6 22,7.8V16.2A5.8,5.8 0 0,1 16.2,22H7.8C4.6,22 2,19.4 2,16.2V7.8A5.8,5.8 0 0,1 7.8,2M7.6,4A3.6,3.6 0 0,0 4,7.6V16.4C4,18.39 5.61,20 7.6,20H16.4A3.6,3.6 0 0,0 20,16.4V7.6C20,5.61 18.39,4 16.4,4H7.6M17.25,5.5A1.25,1.25 0 0,1 18.5,6.75A1.25,1.25 0 0,1 17.25,8A1.25,1.25 0 0,1 16,6.75A1.25,1.25 0 0,1 17.25,5.5M12,7A5,5 0 0,1 17,12A5,5 0 0,1 12,17A5,5 0 0,1 7,12A5,5 0 0,1 12,7M12,9A3,3 0 0,0 9,12A3,3 0 0,0 12,15A3,3 0 0,0 15,12A3,3 0 0,0 12,9Z"></path></svg>
</a></li>
<li class="becky-responsive-hide nav-social" style="float:right;"><a href="http://facebook.com/tellymix"><svg class="facebook" xmlns="http://www.w3.org/2000/svg" fill="#fff" width="20" height="20" viewBox="15.8 15.8 25 25"><path d="M32.8 24.7h-3.2v-2.1c0-0.8 0.5-1 0.9-1s2.3 0 2.3 0v-3.5l-3.1 0c-3.5 0-4.3 2.6-4.3 4.3v2.3h-2v3.6h2c0 4.6 0 10.2 0 10.2h4.2c0 0 0-5.6 0-10.2h2.8L32.8 24.7z"></path></svg>
</a></li>
<li class="becky-responsive-hide nav-social" style="float:right;"><a href="http://youtube.com/tellymixcouk?sub_confirmation=1"> <svg class="youtube" fill="#fff" height="20" viewBox="0 0 24 24" width="20" xmlns="http://www.w3.org/2000/svg"><path d="M10,16.5V7.5L16,12M20,4.4C19.4,4.2 15.7,4 12,4C8.3,4 4.6,4.19 4,4.38C2.44,4.9 2,8.4 2,12C2,15.59 2.44,19.1 4,19.61C4.6,19.81 8.3,20 12,20C15.7,20 19.4,19.81 20,19.61C21.56,19.1 22,15.59 22,12C22,8.4 21.56,4.91 20,4.4Z"></path></svg>
</a></li>
</ul>
<div class="clear"></div>
</nav>
</div>
<div class="clear"></div>
</header>
<nav id="all-links" style="display:none;">
<div class="becky-width">
<a href="/tag/great-british-bake-off">Great British Bake Off</a>
<a href="/tag/the-voice-uk">The Voice UK</a>
<a href="/tag/strictly-come-dancing">Strictly Come Dancing</a>
<a href="/tag/the-masked-singer">The Masked Singer</a>
<a href="/tag/britains-got-talent">Britain&#39;s Got Talent</a>
<a href="/tag/dancing-on-ice">Dancing On Ice</a>
<a href="/tag/im-a-celebrity">I&#39;m A Celebrity</a>
<a href="/tag/celebs-go-dating">Celebs Go Dating</a>
<a href="/tag/love-island">Love Island</a>
<a href="/tag/the-x-factor">X Factor</a>
<a href="/tag/the-apprentice">The Apprentice</a>
<a href="/tag/big-brother">Big Brother</a>
<a href="/tag/the-masked-dancer">The Masked Dancer</a>
<a href="/tag/the-island">The Island</a>
<a href="/tag/disney">Disney+</a>
<a href="/tag/netflix">Netflix</a>
<a href="/tag/made-in-chelsea">Made In Chelsea</a>
<a href="/tag/the-only-way-is-essex">The Only Way Is Essex</a>
<a href="/tag/eurovision">Eurovision</a>
<a href="/ratings">TV Ratings</a>
</div>
</nav> <div id="body" class="becky-width">

<div class="post-608896 post type-post status-publish format-standard has-post-thumbnail hentry category-soaps tag-coronation-street" id="post-608896">
<div class="single-article-header">
<nav id="bc" class="becky-responsive-hide"><p id="breadcrumbs"><a href="https://tellymix.co.uk">TellyMix</a> / <a href="https://tellymix.co.uk/tv-news">News</a> / <a href="https://tellymix.co.uk/soaps" rel="category tag">Soaps</a> / <a href="https://tellymix.co.uk/tag/coronation-street">Coronation Street</a> /</p><script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "BreadcrumbList",
      "itemListElement": [ {
            "@type": "ListItem",
            "position": 1,
            "item": {
              "@id": "https://tellymix.co.uk",
              "name": "TellyMix"
            }
          },{
            "@type": "ListItem",
            "position": 2,
            "item": {
              "@id": "https://tellymix.co.uk/tv-news",
              "name": "News"
            }
          },{
            "@type": "ListItem",
            "position": 3,
            "item": {
              "@id": "https://tellymix.co.uk/soaps",
              "name": "Soaps"
            }
          },{
            "@type": "ListItem",
            "position": 4,
            "item": {
              "@id": "https://tellymix.co.uk/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html",
              "name": "Coronation Street spoilers: Steve McDonald punches Jacob Hay in explosive episode"
            }
          }]
    }
    </script></nav>
<h1 class="entry-title post-title"><a href="https://tellymix.co.uk/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html" title="Coronation Street spoilers: Steve McDonald punches Jacob Hay in explosive episode">Coronation Street spoilers: Steve McDonald punches Jacob Hay in explosive episode</a></h1>
<div class="article-info">Posted <span class="published updated"><time datetime="2022-02-16T08:00:48+00:00">February 16, 2022 08:00</time></span> by <span class="vcard author author_name"><span class="fn">
<a class="url" href="https://tellymix.co.uk/author/joshdarvill">Josh Darvill</a>
</span>
</span>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://tellymix.co.uk/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html"
  },
  "headline": "Coronation Street spoilers: Steve McDonald punches Jacob Hay in explosive episode",
  "image": [
    "https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?fit=1200%2C675&ssl=1"
   ],
  "datePublished": "2022-02-16T08:00:48+00:00",
  "dateModified": "2022-02-16T06:37:53+00:00",
  "author": {
    "@type": "Person",
    "name": "Josh Darvill"
  },
   "publisher": {
    "@type": "Organization",
    "name": "TellyMix",
    "logo": {
      "@type": "ImageObject",
       "url": "https://tellymix.co.uk/wp-content/uploads/2021/01/tellymix-logo.png",
        "height": 59,
        "width":  243
    }
  }
 
}
</script>
</div>
</div>
<section id="content" class="single-article">
<div id="inner-content">
<article id="single">
<div class="bpfs">

<img width="900" height="506" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20900%20506&#39;%3E%3C/svg%3E" class="attachment-article-image size-article-image" alt="Coronation Street: There&#39;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV" data-lazy-srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?w=2000&amp;ssl=1 2000w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 970px) 100vw, (max-width: 1018px) 600px, (max-width: 1250px) 768px, 900px" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?fit=900%2C506&amp;ssl=1" /><noscript><img width="900" height="506" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?fit=900%2C506&amp;ssl=1" class="attachment-article-image size-article-image" alt="Coronation Street: There&#039;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV" srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?w=2000&amp;ssl=1 2000w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 970px) 100vw, (max-width: 1018px) 600px, (max-width: 1250px) 768px, 900px" /></noscript><div class="post-caption" style="margin-bottom:0; padding: 5px;"><div>Coronation Street: There&#39;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV</div></div>
</div>
<div class="bsc">
<div class="dsl">
<a href="https://twitter.com/share?url=https://tellymix.co.uk/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html&amp;text=Coronation+Street+spoilers%3A+Steve+McDonald+punches+Jacob+Hay+in+explosive+episode&amp;via=tellymix" target="_blank" rel="nofollow noopener" class="sbb sbb-twitter">Share on Twitter</a>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://tellymix.co.uk/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html" target="_blank" rel="nofollow noopener" class="sbb sbb-fbk">Share on Facebook</a>
<div class="clear"></div>
</div>

<p class="lead">Steve McDonald and Jacob Hay come to blows in tonight&#39;s episode of Coronation Street.</p>
<p><span id="more-608896"></span></p>
<p>In this evening&#39;s instalment of the ITV soap, Steve finally sees red over his daughter’s relationship with the former drug dealer. </p><div class="adb_top">
<span class="a-text">
Advertisements</span>
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7416743337323842" data-ad-slot="8908380993"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>A teaser shares: &#34;Tensions reach breaking point in tonight’s episodes when Steve orders Jacob to stay away from Amy after her drink was spiked in a club. With the suspicion falling solely on Jacob due to his unsavory past with drugs, he has no choice but to try to convince the Barlows that he is innocent. </p>
<p>&#34;However Jacob will face the wrath of protective dad, Steve, who is hellbent on separating the teen star crossed lovers. &#34;</p>
<p>Actor Jack James Ryan, who plays Jacob, says of the filming the scenes: &#34;Jacob is incredibly nervous because he is so keen to make a good impression. Jacob is fully aware of what Steve and Tracy think and feel about him so he is really eager to come across well to them.&#34;</p>
<div class="post-caption" id="attachment_608903"><img src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20900%20506&#39;%3E%3C/svg%3E" alt="Coronation Street: There&#39;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV" width="900" height="506" class="size-article-image wp-image-608903" data-lazy-srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=1500%2C843&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=1200%2C674&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=600%2C337&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=400%2C225&amp;ssl=1 400w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?w=2000&amp;ssl=1 2000w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=900%2C506&amp;ssl=1" /><noscript><img src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=900%2C506&#038;ssl=1" alt="Coronation Street: There&#039;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV" width="900" height="506" class="size-article-image wp-image-608903" srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=1500%2C843&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=1200%2C674&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=600%2C337&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?resize=400%2C225&amp;ssl=1 400w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_02.jpg?w=2000&amp;ssl=1 2000w" sizes="(max-width: 900px) 100vw, 900px" data-recalc-dims="1" /></noscript> <div> Coronation Street: There&#39;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV</div></div>
<p>Speaking about Steve ordering Jacob to stay away from Amy, he continues: &#34;Jacob is absolutely gutted because he really does like Amy. He has genuine feelings towards her and he sees this new life and a new beginning for himself with Amy so when Steve tells him he can’t see her anymore he feels a lot of emotion and it crushes him. What </p>
<p>&#34;Jacob and Amy have is something really special and it makes him feel wanted, which is something he has never had or felt in his life before. He doesn’t want to go against Steve but he sees a future with Amy and he really wants to fight for her.&#34;</p>
<p>Jack shares on the punch from Steve: &#34;Amy’s drink has been spiked and a lot of fingers are pointing at Jacob which is understandable given his past with drugs. All Jacob wants to do is see Amy but Steve wants him to have nothing to do with his daughter. Jacob is being persistent and he brings sandwiches and crisps for Steve and Tracy to try and help. </p>
<div class="adb_top">
<span class="a-text">
Advertisements</span>
<div style="height:280px; text-align:center;">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7416743337323842" data-ad-slot="5161919157" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<p>&#34;Steve asks Jacob to leave but Jacob is pleading with Steve to let him stay. Steve’s son, Oliver, is mentioned so Steve sees red and punches Jacob. Jacob is totally shocked by this; he is totally surprised and didn’t expect Steve to do that. Jacob is so disappointed because now he knows at this point, it’s going to be near impossible to win them over. </p>
<p>&#34;But Jacob is going to continue to fight for Amy.&#34;</p>
<p>Jack and fellow actor Simon Gregson wee put into a &#39;bubble&#39; to film the scenes safely.</p>
<p>He continued: &#34;It was really exciting, the high action scenes are always great fun to film. We had a fight arranger and Simon and I went through the actions. We had a few different ideas of how we could make it work, trying things and then watching it back on camera to see what worked well. I think we came up with something that looks really cool. </p>
<div class="post-caption" id="attachment_608905"><img src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20900%20506&#39;%3E%3C/svg%3E" alt="Coronation Street: There&#39;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV" width="900" height="506" class="size-article-image wp-image-608905" data-lazy-srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=400%2C225&amp;ssl=1 400w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?w=2000&amp;ssl=1 2000w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=900%2C506&amp;ssl=1" /><noscript><img src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=900%2C506&#038;ssl=1" alt="Coronation Street: There&#039;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV" width="900" height="506" class="size-article-image wp-image-608905" srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?resize=400%2C225&amp;ssl=1 400w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_04.jpg?w=2000&amp;ssl=1 2000w" sizes="(max-width: 900px) 100vw, 900px" data-recalc-dims="1" /></noscript> <div> Coronation Street: There&#39;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV</div></div>
<p>&#34;It is difficult to get the angles right when filming these sorts of scenes - you can’t just punch an actor! - so it has to be done in the right way. It’s very precise so we did a few takes before we felt we had got it spot on and perfect. In the end, everyone was really happy with it and I am really excited to see the end result myself.&#34;</p>
<p>Jack added: &#34;Simon has been amazing. He is iconic to the show and he is a brilliant actor so it’s been really great to be able to work with him and learn things from him on set - I have been soaking it all in! </p>
<div class="adb_top">
<span class="a-text">
Advertisements</span>
<script class="__lxGc__" type="text/javascript">
((__lxGc__=window.__lxGc__||{'s':{},'b':0})['s']['_194647']=__lxGc__['s']['_194647']||{'b':{}})['b']['_607873']={'i':__lxGc__.b++};
</script>
</div>
<p>&#34;Simon is everything you would expect him to be; he is really funny and we are laughing all the time. I have such a great time working with him and I am really excited to see the scenes on screen this week because I feel like we have worked really well together.&#34;</p>
<p><strong>Coronation Street airs on ITV and ITV Hub.</strong></p>
<div id="rcjsload_15438f"></div>
<script type="text/javascript">
(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "https://trends.revcontent.com/serve.js.php?w=9887&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
var rcds = document.getElementById("rcjsload_15438f"); rcds.appendChild(rcel);
})();
</script>
<div class="clear becky-single-end-more-box">
<strong>More on:</strong>
<a href="https://tellymix.co.uk/tag/coronation-street" rel="tag">Coronation Street</a> <a href="https://tellymix.co.uk/soaps" rel="category tag">Soaps</a> </div>
<div class="dsl">
<a href="https://twitter.com/share?url=https://tellymix.co.uk/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html&amp;text=Coronation+Street+spoilers%3A+Steve+McDonald+punches+Jacob+Hay+in+explosive+episode&amp;via=tellymix" target="_blank" rel="nofollow noopener" class="sbb sbb-twitter">Share on Twitter</a>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://tellymix.co.uk/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html" target="_blank" rel="nofollow noopener" class="sbb sbb-fbk">Share on Facebook</a>
<div class="clear"></div>
</div>
<div class="clear"></div>
</div>
</article>
<div class="becky-social-post-article clr">
<div class="bsbb bsbb-twitter becky-responsive-hide">
<h5>Follow on <span>Twitter</span></h5>
<a rel="nofollow noopener" target="_blank" class="twitter-cat-fbtn" href="https://twitter.com/intent/follow?screen_name=tellymix">Follow @tellymix</a> </div>
<div class="bsbb bsbb-twitter becky-responsive-show">
<h5>Follow on <span>Twitter</span></h5>
<a rel="nofollow noopener" target="_blank" class="twitter-cat-fbtn" href="https://twitter.com/intent/follow?screen_name=tellymix">Follow @tellymix</a> </div>
<div class="bsbb bsbb-fbk"><h5>Like on <span>Facebook</span></h5>
<a rel="nofollow noopener" class="twitter-cat-fbtn fbk-cat-fbtn" target="_blank" href="https://facebook.com/tellymix">Like @tellymix</a></div>
<div class="clear"></div> </div>
</div>
</section>
</div>


<aside id="sidebar">
<style type="text/css">

             .sldbdd { display: block; height: 600px; }
    .ak-text { padding-bottom: 9px;}
             
             @media (max-width: 970px) { .sldbdd, .ak-text { display: none; } }
             
</style>
<span class="a-text ak-text">
Advertisements</span>
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle sldbdd" data-ad-client="ca-pub-7416743337323842" data-ad-slot="5018438481" data-ad-format="vertical" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<br /><br />




<div class="sidebar-box">
<h3>popular now</h3>
<ul>
<li>
<a href="https://tellymix.co.uk/tv/572765-peaky-blinders-series-6-date-cast-trailer.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="peaky blinders season 6 trailer" data-lazy-srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?w=1280&amp;ssl=1 1280w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=900%2C506&amp;ssl=1 900w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=500%2C281&amp;ssl=1 500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="peaky blinders season 6 trailer" srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?w=1280&amp;ssl=1 1280w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=900%2C506&amp;ssl=1 900w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=500%2C281&amp;ssl=1 500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Peaky Blinders release date and trailer for final series revealed</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/reality-tv/608851-dancing-on-ices-brendan-cole-to-skate-with-brendyn-hatfield-after-vanessa-bauer-tests-positive-for-covid.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="dancing on ice brendan brendyn" data-lazy-srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?w=1920&amp;ssl=1 1920w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="dancing on ice brendan brendyn" srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?w=1920&amp;ssl=1 1920w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-brendan-brendyn.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Dancing On Ice&#39;s Brendan Cole to skate with Brendyn Hatfield after Vanessa Bauer tests positive for Covid</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/streaming/578507-bridgerton-season-2-release-date-cast-trailer.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="netflix bridgerton season 2 trailer" data-lazy-srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="netflix bridgerton season 2 trailer" srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/netflix-bridgerton-season-2-trailer.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Bridgerton season 2 release date and first trailer revealed!</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/reality-tv/608564-the-masked-singer-uk-set-to-return-for-a-fourth-series-next-year.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="The Masked Singer: SR3: Ep5 on ITV and ITV Hub. Pictured: Panda. ©Bandicoot TV" data-lazy-srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?w=2000&amp;ssl=1 2000w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=900%2C506&amp;ssl=1 900w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=500%2C281&amp;ssl=1 500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="The Masked Singer: SR3: Ep5 on ITV and ITV Hub. Pictured: Panda. ©Bandicoot TV" srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?w=2000&amp;ssl=1 2000w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=900%2C506&amp;ssl=1 900w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=500%2C281&amp;ssl=1 500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/the_masked_singer_sr3_ep5_21.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>The Masked Singer UK to return for TWO new series</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/reality-tv/608093-dancing-on-ice-2022-results-who-left-fourth-celebrity-voted-off-in-latest-live-show.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="dancing on ice 2022 week 5 results" data-lazy-srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=2000%2C1125&amp;ssl=1 2000w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=400%2C225&amp;ssl=1 400w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?w=2400&amp;ssl=1 2400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="dancing on ice 2022 week 5 results" srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=2000%2C1125&amp;ssl=1 2000w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?resize=400%2C225&amp;ssl=1 400w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/dancing-on-ice-2022-week-5-results-scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Dancing On Ice 2022 results! Fourth celebrity voted off in latest live show</span>
<div class="clear"></div>
</a>
</li>
</ul>
</div>

<div class="sidebar-aaa" style="margin-bottom: 25px;">
</div>
<div class="sidebar-related-posts sidebar-related-posts-wrapper">



<div class="sidebar-box">
<h3>latest news</h3>
<ul>
<li>
<a href="https://tellymix.co.uk/soaps/608896-coronation-street-spoilers-steve-mcdonald-punches-jacob-hay-in-explosive-episode.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="Coronation Street: There&#39;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV" data-lazy-srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?w=2000&amp;ssl=1 2000w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="Coronation Street: There&#039;s a commotion in the hospital corridor and Tracy and Amy dash out just in time to see Steve punching Jacob. Copyright ITV" srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?w=2000&amp;ssl=1 2000w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/16_02_CORO_STEVE_JACOB_1ST_EP_03.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Coronation Street spoilers: Steve McDonald punches Jacob Hay in explosive episode</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/tv/535825-the-repair-shop-new-series-2021-episodes-and-how-to-watch-online.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="the repair shop" data-lazy-srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?w=1808&amp;ssl=1 1808w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=220%2C123&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="the repair shop" srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?w=1808&amp;ssl=1 1808w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=220%2C123&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2021/02/the-repair-shop.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>The Repair Shop 2022 - tonight&#39;s episode and how to watch online</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/streaming/608860-culprits-cast-revealed-for-new-british-drama-coming-to-disney.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="disney+ logo" data-lazy-srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?w=1920&amp;ssl=1 1920w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="disney+ logo" srcset="https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?w=1920&amp;ssl=1 1920w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=220%2C124&amp;ssl=1 220w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=160%2C90&amp;ssl=1 160w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=900%2C506&amp;ssl=1 900w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=500%2C281&amp;ssl=1 500w, https://i1.wp.com/tellymix.co.uk/wp-content/uploads/2022/02/disney-logo.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Culprits: Cast revealed for new British drama coming to Disney+</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/reality-tv/607710-rupauls-drag-race-uk-versus-the-world-results-who-left-this-week-and-contestants-from-new-series.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="RuPaul&#39;s Drag Race UK vs The World - (C) World of Wonder - Photographer: Guy Levy" data-lazy-srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?w=2000&amp;ssl=1 2000w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="RuPaul&#039;s Drag Race UK vs The World - (C) World of Wonder - Photographer: Guy Levy" srcset="https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?w=2000&amp;ssl=1 2000w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=1500%2C844&amp;ssl=1 1500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=220%2C124&amp;ssl=1 220w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=160%2C90&amp;ssl=1 160w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=900%2C506&amp;ssl=1 900w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=500%2C281&amp;ssl=1 500w, https://i0.wp.com/tellymix.co.uk/wp-content/uploads/2022/01/24171694-low-.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>RuPaul&#39;s Drag Race UK Versus The World results: Who left this week and contestants from new series</span>
<div class="clear"></div>
</a>
</li>
<li>
<a href="https://tellymix.co.uk/tv/572765-peaky-blinders-series-6-date-cast-trailer.html">
<img width="160" height="90" src="data:image/svg+xml,%3Csvg%20xmlns=&#39;http://www.w3.org/2000/svg&#39;%20viewBox=&#39;0%200%20160%2090&#39;%3E%3C/svg%3E" class="attachment-sidebar-image size-sidebar-image" alt="peaky blinders season 6 trailer" data-lazy-srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?w=1280&amp;ssl=1 1280w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=900%2C506&amp;ssl=1 900w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=500%2C281&amp;ssl=1 500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=400%2C225&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=160%2C90&amp;ssl=1" /><noscript><img width="160" height="90" src="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=160%2C90&amp;ssl=1" class="attachment-sidebar-image size-sidebar-image" alt="peaky blinders season 6 trailer" srcset="https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?w=1280&amp;ssl=1 1280w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=220%2C124&amp;ssl=1 220w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=160%2C90&amp;ssl=1 160w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=900%2C506&amp;ssl=1 900w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=500%2C281&amp;ssl=1 500w, https://i2.wp.com/tellymix.co.uk/wp-content/uploads/2021/12/peaky-blinders-season-6-trailer.jpg?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 160px) 100vw, 160px" /></noscript>
<span>Peaky Blinders release date and trailer for final series revealed</span>
<div class="clear"></div>
</a>
</li>
</ul>
</div>
</div>
<div class="adb_top">
<span class="a-text">
Advertisements</span>
<script class="__lxGc__" type="text/javascript">
((__lxGc__=window.__lxGc__||{'s':{},'b':0})['s']['_194647']=__lxGc__['s']['_194647']||{'b':{}})['b']['_604220']={'i':__lxGc__.b++};
</script>
</div>
</aside>
<div class="clear"></div>
</div> 
<footer>

<div class="footer-content">
<div class="becky-width clr" style="text-align:center;">
<p>
<a href="/">Home</a>    
<a href="/about">About us</a>    
<a href="/about/writers">Meet the team</a>    
<a href="/contact">Contact</a>    
<a href="/about/privacy-and-cookies-policy">Privacy &amp; Cookies policy</a>    
<a href="#" onclick="if(window.__lxG__consent__ !== undefined) {window.__lxG__consent__.showConsent()} else {alert(&#39;This function only for users from European Economic Area (EEA)&#39;)}; return false">Privacy Settings / Opt out</a>
</p>
<p>© 2021. All Rights Reserved TellyMix unless otherwise stated. </p>
</div>
</div>
 </footer>
</div> 

<script type="text/javascript">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</script>
<meta name="twitter:widgets:autoload" content="off" />

<script>

    
    
    
jQuery(document).ready(function() {
	
	var panel = jQuery("#mobile-sidebar");

	jQuery("#mobile-menu").click(function() {
		if(panel.css("display") == "none") {
			panel.show();
		} else { panel.hide(); }
	});

	jQuery("#close-menu").click(function() { panel.hide(); });

		

});
</script>

<script type="text/javascript">var _merchantSettings=_merchantSettings || [];_merchantSettings.push(['AT', '10lt4w']);(function(){var autolink=document.createElement('script');autolink.type='text/javascript';autolink.async=true; autolink.src= ('https:' == document.location.protocol) ? 'https://autolinkmaker.itunes.apple.com/js/itunes_autolinkmaker.js' : 'http://autolinkmaker.itunes.apple.com/js/itunes_autolinkmaker.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(autolink, s);})();</script>
<script type="text/javascript" defer="" src="https://s.skimresources.com/js/6380X656712.skimlinks.js"></script>
<script type="text/javascript">
jQuery(document).ready(function() {
	
	var submenus = jQuery(".all-links-controller");

	submenus.click(function() {
		var submenu = jQuery("#all-links");

		submenu.slideToggle(400);
	return false;
	});



});
</script>

<script type="text/javascript" src="https://c0.wp.com/p/jetpack/10.4/_inc/build/photon/photon.min.js" id="jetpack-photon-js" defer=""></script>
<script src="https://stats.wp.com/e-202207.js" defer=""></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.4',blog:'11844673',post:'608896',tz:'0',srv:'tellymix.co.uk'} ]);
	_stq.push([ 'clickTrackerInit', '11844673', '608896' ]);
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async="" src="https://tellymix.co.uk/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<button class="play" aria-label="play Youtube video"></button>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.parentNode.dataset.query.length?'':'&'+this.parentNode.dataset.query;e.setAttribute("src",t.replace("ID",this.parentNode.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.parentNode.replaceChild(e,this.parentNode)}document.addEventListener("DOMContentLoaded",function(){var e,t,p,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),a[t].appendChild(e),p=e.querySelector('.play'),p.onclick=lazyLoadYoutubeIframe});</script>
</body></html>